summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2022-07-23 09:39:19 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2022-07-23 09:39:37 -0700
commit168aed309a8a063132b5c7afa20fbc5371b23410 (patch)
tree40be88ce5497c54a3b691291dcfefb9d3be60d6a /app-emulation
parentapp-emulation/ganeti: cleanup old ebuilds (diff)
downloadgentoo-168aed309a8a063132b5c7afa20fbc5371b23410.tar.gz
gentoo-168aed309a8a063132b5c7afa20fbc5371b23410.tar.bz2
gentoo-168aed309a8a063132b5c7afa20fbc5371b23410.zip
app-emulation/ganeti: cleanup & update to EAPI8
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ganeti-3.0.2-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-emulation/ganeti/ganeti-3.0.2-r2.ebuild b/app-emulation/ganeti/ganeti-3.0.2-r2.ebuild
index bf35bdba6614..63cf7b305b44 100644
--- a/app-emulation/ganeti/ganeti-3.0.2-r2.ebuild
+++ b/app-emulation/ganeti/ganeti-3.0.2-r2.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+# As of 3.0.2, Upstream does NOT yet support newer than python3.8
PYTHON_COMPAT=(python3_{7..8})
PYTHON_REQ_USE="ipv6(+)?"
-inherit user autotools bash-completion-r1 python-single-r1 tmpfiles versionator
+inherit autotools bash-completion-r1 python-single-r1 tmpfiles
MY_PV="${PV/_rc/~rc}"
MY_PV="${MY_PV/_beta/~beta}"
MY_P="${PN}-${MY_PV}"
-SERIES="$(get_version_component_range 1-2)"
+SERIES="3.0"
if [[ ${PV} =~ [9]{4,} ]] ; then
EGIT_REPO_URI="git://git.ganeti.org/ganeti.git"
@@ -136,8 +137,7 @@ DEPEND="
rbd? ( sys-cluster/ceph )
ipv6? ( net-misc/ndisc6 )
${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- !app-emulation/ganeti-htools"
+RDEPEND="${DEPEND}"
DEPEND+="
sys-devel/m4
app-text/pandoc