summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-13 03:50:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-13 04:07:26 -0400
commit11e9fe6867cb3658c588626599264ad9fb2f8f83 (patch)
tree9f7183781a441e4e545890d69183a537321be3ce /app-emulation
parentapp-emacs/ebuild-mode: drop 1.60, 1.61 (diff)
downloadgentoo-11e9fe6867cb3658c588626599264ad9fb2f8f83.tar.gz
gentoo-11e9fe6867cb3658c588626599264ad9fb2f8f83.tar.bz2
gentoo-11e9fe6867cb3658c588626599264ad9fb2f8f83.zip
app-emulation/wine-staging: update to use winehq's gitlab
Migrated leaving github as a mirror. Leaving the old SRC_URIs alone, and update in 9999 for use with next release (assuming that it still doesn't get proper release artifacts on dl.winehq.org). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-8.0.ebuild6
-rw-r--r--app-emulation/wine-staging/wine-staging-8.5.ebuild6
-rw-r--r--app-emulation/wine-staging/wine-staging-8.6.1.ebuild6
-rw-r--r--app-emulation/wine-staging/wine-staging-8.7.ebuild4
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild8
5 files changed, 20 insertions, 10 deletions
diff --git a/app-emulation/wine-staging/wine-staging-8.0.ebuild b/app-emulation/wine-staging/wine-staging-8.0.ebuild
index 3b1d7f1ce6fe..06a39f07e0f3 100644
--- a/app-emulation/wine-staging/wine-staging-8.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.0.ebuild
@@ -11,7 +11,7 @@ WINE_MONO=7.4.0
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/wine-staging/wine-staging.git"
+ EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine-staging.git"
WINE_EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine.git"
else
(( $(ver_cut 2) )) && WINE_SDIR=$(ver_cut 1).x || WINE_SDIR=$(ver_cut 1).0
@@ -23,7 +23,9 @@ fi
S="${WORKDIR}/wine-${PV}"
DESCRIPTION="Free implementation of Windows(tm) on Unix, with Wine-Staging patchset"
-HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
+HOMEPAGE="
+ https://wiki.winehq.org/Wine-Staging
+ https://gitlab.winehq.org/wine/wine-staging/"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
diff --git a/app-emulation/wine-staging/wine-staging-8.5.ebuild b/app-emulation/wine-staging/wine-staging-8.5.ebuild
index 1f2310f1a252..1d9218bfa197 100644
--- a/app-emulation/wine-staging/wine-staging-8.5.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.5.ebuild
@@ -13,7 +13,7 @@ WINE_MONO=7.4.0
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/wine-staging/wine-staging.git"
+ EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine-staging.git"
WINE_EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine.git"
else
(( $(ver_cut 2) )) && WINE_SDIR=$(ver_cut 1).x || WINE_SDIR=$(ver_cut 1).0
@@ -25,7 +25,9 @@ fi
S="${WORKDIR}/wine-${PV}"
DESCRIPTION="Free implementation of Windows(tm) on Unix, with Wine-Staging patchset"
-HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
+HOMEPAGE="
+ https://wiki.winehq.org/Wine-Staging
+ https://gitlab.winehq.org/wine/wine-staging/"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
diff --git a/app-emulation/wine-staging/wine-staging-8.6.1.ebuild b/app-emulation/wine-staging/wine-staging-8.6.1.ebuild
index ad9ce9a33eff..cab12fde862c 100644
--- a/app-emulation/wine-staging/wine-staging-8.6.1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.6.1.ebuild
@@ -13,7 +13,7 @@ WINE_MONO=7.4.0
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/wine-staging/wine-staging.git"
+ EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine-staging.git"
WINE_EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine.git"
else
(( $(ver_cut 2) )) && WINE_SDIR=$(ver_cut 1).x || WINE_SDIR=$(ver_cut 1).0
@@ -25,7 +25,9 @@ fi
S="${WORKDIR}/wine-$(ver_cut 1-2)"
DESCRIPTION="Free implementation of Windows(tm) on Unix, with Wine-Staging patchset"
-HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
+HOMEPAGE="
+ https://wiki.winehq.org/Wine-Staging
+ https://gitlab.winehq.org/wine/wine-staging/"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
diff --git a/app-emulation/wine-staging/wine-staging-8.7.ebuild b/app-emulation/wine-staging/wine-staging-8.7.ebuild
index 0865619a8b23..f7296349f46f 100644
--- a/app-emulation/wine-staging/wine-staging-8.7.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.7.ebuild
@@ -25,7 +25,9 @@ fi
S="${WORKDIR}/wine-${PV}"
DESCRIPTION="Free implementation of Windows(tm) on Unix, with Wine-Staging patchset"
-HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
+HOMEPAGE="
+ https://wiki.winehq.org/Wine-Staging
+ https://gitlab.winehq.org/wine/wine-staging/"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 0865619a8b23..bbf0f0ca9656 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -13,19 +13,21 @@ WINE_MONO=7.4.0
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/wine-staging/wine-staging.git"
+ EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine-staging.git"
WINE_EGIT_REPO_URI="https://gitlab.winehq.org/wine/wine.git"
else
(( $(ver_cut 2) )) && WINE_SDIR=$(ver_cut 1).x || WINE_SDIR=$(ver_cut 1).0
SRC_URI="
https://dl.winehq.org/wine/source/${WINE_SDIR}/wine-${PV}.tar.xz
- https://github.com/wine-staging/wine-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ https://gitlab.winehq.org/wine/wine-staging/-/archive/v${PV}/${P}.tar.bz2"
KEYWORDS="-* ~amd64 ~x86"
fi
S="${WORKDIR}/wine-${PV}"
DESCRIPTION="Free implementation of Windows(tm) on Unix, with Wine-Staging patchset"
-HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
+HOMEPAGE="
+ https://wiki.winehq.org/Wine-Staging
+ https://gitlab.winehq.org/wine/wine-staging/"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"