summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-06-04 11:14:05 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-06-04 11:15:13 -0400
commite88ba4d4228598324cdfee830e76b9b580e5428f (patch)
tree178295046cc255b50351ae0e24b460ba3dbbec80 /app-emulation/wine-mono
parentdev-python/xxhash: Add python@ as co-maint. (diff)
downloadgentoo-e88ba4d4228598324cdfee830e76b9b580e5428f.tar.gz
gentoo-e88ba4d4228598324cdfee830e76b9b580e5428f.tar.bz2
gentoo-e88ba4d4228598324cdfee830e76b9b580e5428f.zip
app-emulation/wine-mono: Version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-7.3.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index 0bea0023c2cd..f91d18c12a82 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -8,3 +8,5 @@ DIST wine-mono-7.1.1-x86.msi 86606336 BLAKE2B 817d02bc090e5f324519a118de53a51510
DIST wine-mono-7.1.1-x86.tar.xz 45220396 BLAKE2B 8a4cfa9496a51adb884c9062162413564cb939624ec551e97467eed41efc6e67e6296b2b0924eaa9565e98ea5595e140db691f23ef28edbf16456e3f6d39bd05 SHA512 b52f8a71900a34c687fd86559db16f2b7a3abe0f3965b5050e1859646c7bb00e070cc394f9a175995ccb50501d15844853b49931a7ac7cd2022581e241f31924
DIST wine-mono-7.2.0-x86.msi 86910464 BLAKE2B 4e07c88202b85141faa5fe66e8254839f9d048922fcae6f71468273c1443c148f32746f0cc58b8c16f4f5c46678076072ae5a443e090371ad863387f4c5f15f0 SHA512 855a829a247de1e6ee31e07d06cc9d23b3011f43937c13a04f992fbc99080c32cd2dfc44e07bbdf6a71935b75192dd0648288c622eae00b3226e3c58ff55d826
DIST wine-mono-7.2.0-x86.tar.xz 42477712 BLAKE2B f82e5b16b7f6554d919fa082eaa1686a22b798b1cf377aaa6b29f67682749a6e851cd3ee4d52a227c8d279442ed018704a92e3917593de70e588b47a7635395b SHA512 791c93425f37dfb7d481f0afb1b15bd18b084a764d70d2bf211fe791c94c44673940177870dae898e6b0adf3bf08f01f0ecb2fc1c5783c96f4ed4cede8fdb34d
+DIST wine-mono-7.3.0-x86.msi 86919680 BLAKE2B 917aa260ba7a012ed1e1565f8ed23225c82060c82dbb74a1e0d105a7b38a1d840c20689e0a8e7cc1a5c5de938807c78f36c98cbef07270accaf789b6b031f22d SHA512 d92ab4a9d0ac1c48dfec583b1681317e9ec9556efcb18766a865bee06a3a53ea08159099ca3ec92149f677d67583648991d59adb9b8a612ef41de06da8c77fd2
+DIST wine-mono-7.3.0-x86.tar.xz 43557004 BLAKE2B 919912faf97cf38b2fcc9813de4e035d907b0a00db78d2a251c1c43dab65ba44847ecbf494a15dba761d9ba8203855c1a6e5f5bbd07f20484c9948c3cfe4d3bc SHA512 c26dc21d0d462b3c79e778497815e33d26b5ab545eba0552b436f30d9b7aa340ccdef69fe0dcbf32c04330e6d0f813314646ded7d2d24e6f4746e4893adbbf7f
diff --git a/app-emulation/wine-mono/wine-mono-7.3.0.ebuild b/app-emulation/wine-mono/wine-mono-7.3.0.ebuild
new file mode 100644
index 000000000000..0836b039a90f
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}