summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-09-13 17:09:00 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-09-13 17:09:00 -0400
commit32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2 (patch)
treee57d2a319da4b7aa5cb93083427134bf003d4f9a /app-emulation/wine-any/wine-any-9999.ebuild
parentapp-emulation/wine-d3d9: Fix xdg-utils.eclass migration (diff)
downloadgentoo-32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2.tar.gz
gentoo-32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2.tar.bz2
gentoo-32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2.zip
app-emulation/wine-any: Fix xdg-utils.eclass migration
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-emulation/wine-any/wine-any-9999.ebuild')
-rw-r--r--app-emulation/wine-any/wine-any-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-emulation/wine-any/wine-any-9999.ebuild b/app-emulation/wine-any/wine-any-9999.ebuild
index 4be5512a8ff7..323eeca67775 100644
--- a/app-emulation/wine-any/wine-any-9999.ebuild
+++ b/app-emulation/wine-any/wine-any-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}