summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-08-17 10:24:09 +0800
committerYixun Lan <dlan@gentoo.org>2016-08-17 14:36:25 +0800
commite2af4e0d2702e14a8f76ba65525ff36b10a2b535 (patch)
tree8b8d0ee4a0cce3477a6e09d1a5e823be1d827c41 /app-emulation/spice
parentapp-emulation/spice: version bump 0.13.2 (diff)
downloadgentoo-e2af4e0d2702e14a8f76ba65525ff36b10a2b535.tar.gz
gentoo-e2af4e0d2702e14a8f76ba65525ff36b10a2b535.tar.bz2
gentoo-e2af4e0d2702e14a8f76ba65525ff36b10a2b535.zip
app-emulation/spice: live ebuilds updated
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/spice-9999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index 03693f6d7c12..a5f3f7fe07b5 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4} )
-inherit eutils git-r3 python-any-r1 autotools
+inherit eutils git-r3 python-any-r1 autotools readme.gentoo-r1
DESCRIPTION="SPICE server"
HOMEPAGE="http://spice-space.org/"
@@ -16,7 +16,7 @@ EGIT_REPO_URI="git://git.freedesktop.org/git/spice/spice"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="libressl lz4 sasl smartcard static-libs"
+IUSE="libressl lz4 sasl smartcard static-libs gstreamer"
RDEPEND="
>=dev-libs/glib-2.22:2[static-libs(+)?]
@@ -29,7 +29,8 @@ RDEPEND="
libressl? ( dev-libs/libressl[static-libs(+)?] )
lz4? ( app-arch/lz4 )
smartcard? ( >=app-emulation/libcacard-0.1.2 )
- sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )"
+ sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
+ gstreamer? ( media-libs/gstreamer:1.0 )"
DEPEND="
=app-emulation/spice-protocol-9999
@@ -55,22 +56,25 @@ pkg_setup() {
}
src_prepare() {
- epatch_user
-
- eautoreconf
default
+ eautoreconf
}
src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable lz4) \
- $(use_with sasl) \
- $(use_enable smartcard) \
+ local myconf="
+ $(use_enable static-libs static)
+ $(use_enable lz4)
+ $(use_with sasl)
+ $(use_enable smartcard)
+ $(usex gstreamer "1.0" "no")
+ --enable-celt051
--disable-gui
+ "
+ econf ${myconf}
}
src_install() {
default
use static-libs || prune_libtool_files
+ readme.gentoo_create_doc
}