summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-30 22:06:43 +0100
committerSam James <sam@gentoo.org>2024-08-30 22:09:24 +0100
commite6128b3ae9c452bb77e08fc0924ed97c7ed0dafa (patch)
tree7ad47e9e16a9ca012b0d4307315f8d1ffaf00203 /app-emulation/qemu
parentapp-emulation/qemu: SystemTAP -> SystemTap (diff)
downloadgentoo-e6128b3ae9c452bb77e08fc0924ed97c7ed0dafa.tar.gz
gentoo-e6128b3ae9c452bb77e08fc0924ed97c7ed0dafa.tar.bz2
gentoo-e6128b3ae9c452bb77e08fc0924ed97c7ed0dafa.zip
app-emulation/qemu: handle dev-debug/systemtap[-dtrace-symlink]
See efb3a82e3496d3a52a1d04d4cbdb83b25655d96a. Bug: https://bugs.gentoo.org/938302 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-7.2.11.ebuild8
-rw-r--r--app-emulation/qemu/qemu-7.2.12.ebuild8
-rw-r--r--app-emulation/qemu/qemu-7.2.13.ebuild8
-rw-r--r--app-emulation/qemu/qemu-8.0.5.ebuild8
-rw-r--r--app-emulation/qemu/qemu-8.1.5.ebuild8
-rw-r--r--app-emulation/qemu/qemu-8.2.3.ebuild8
-rw-r--r--app-emulation/qemu/qemu-8.2.5.ebuild8
-rw-r--r--app-emulation/qemu/qemu-8.2.6.ebuild8
-rw-r--r--app-emulation/qemu/qemu-9.0.1.ebuild8
-rw-r--r--app-emulation/qemu/qemu-9.0.2.ebuild8
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild8
11 files changed, 88 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-7.2.11.ebuild b/app-emulation/qemu/qemu-7.2.11.ebuild
index 0bd95eb2aa6f..5a9af9426352 100644
--- a/app-emulation/qemu/qemu-7.2.11.ebuild
+++ b/app-emulation/qemu/qemu-7.2.11.ebuild
@@ -451,6 +451,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-7.2.12.ebuild b/app-emulation/qemu/qemu-7.2.12.ebuild
index 538cedf413cb..d9dab196a8bb 100644
--- a/app-emulation/qemu/qemu-7.2.12.ebuild
+++ b/app-emulation/qemu/qemu-7.2.12.ebuild
@@ -451,6 +451,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-7.2.13.ebuild b/app-emulation/qemu/qemu-7.2.13.ebuild
index 538cedf413cb..d9dab196a8bb 100644
--- a/app-emulation/qemu/qemu-7.2.13.ebuild
+++ b/app-emulation/qemu/qemu-7.2.13.ebuild
@@ -451,6 +451,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-8.0.5.ebuild b/app-emulation/qemu/qemu-8.0.5.ebuild
index 6d738816fd22..d1a99943c1f8 100644
--- a/app-emulation/qemu/qemu-8.0.5.ebuild
+++ b/app-emulation/qemu/qemu-8.0.5.ebuild
@@ -454,6 +454,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-8.1.5.ebuild b/app-emulation/qemu/qemu-8.1.5.ebuild
index 44bd836d8e13..f25b0b58db19 100644
--- a/app-emulation/qemu/qemu-8.1.5.ebuild
+++ b/app-emulation/qemu/qemu-8.1.5.ebuild
@@ -455,6 +455,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-8.2.3.ebuild b/app-emulation/qemu/qemu-8.2.3.ebuild
index 72f48df8ec10..cd2bb3a7f555 100644
--- a/app-emulation/qemu/qemu-8.2.3.ebuild
+++ b/app-emulation/qemu/qemu-8.2.3.ebuild
@@ -475,6 +475,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-8.2.5.ebuild b/app-emulation/qemu/qemu-8.2.5.ebuild
index 849ea6e4dc5e..fa173f859c86 100644
--- a/app-emulation/qemu/qemu-8.2.5.ebuild
+++ b/app-emulation/qemu/qemu-8.2.5.ebuild
@@ -475,6 +475,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-8.2.6.ebuild b/app-emulation/qemu/qemu-8.2.6.ebuild
index 849ea6e4dc5e..fa173f859c86 100644
--- a/app-emulation/qemu/qemu-8.2.6.ebuild
+++ b/app-emulation/qemu/qemu-8.2.6.ebuild
@@ -475,6 +475,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-9.0.1.ebuild b/app-emulation/qemu/qemu-9.0.1.ebuild
index 610a93a7a117..fe1feb38bc89 100644
--- a/app-emulation/qemu/qemu-9.0.1.ebuild
+++ b/app-emulation/qemu/qemu-9.0.1.ebuild
@@ -479,6 +479,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-9.0.2.ebuild b/app-emulation/qemu/qemu-9.0.2.ebuild
index 610a93a7a117..fe1feb38bc89 100644
--- a/app-emulation/qemu/qemu-9.0.2.ebuild
+++ b/app-emulation/qemu/qemu-9.0.2.ebuild
@@ -479,6 +479,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 8fe5f7f2ee67..3811b8699f12 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -478,6 +478,14 @@ src_prepare() {
tc-export AR AS LD NM OBJCOPY PKG_CONFIG RANLIB STRINGS
export WINDRES=${CHOST}-windres
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
# Verbose builds
MAKEOPTS+=" V=1"