summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-04-28 16:48:08 +0200
committerSam James <sam@gentoo.org>2024-04-29 02:26:20 +0100
commitd6f20b2493dd5a01308582403e31050b33037508 (patch)
treec3cac7accbd3cfaf0bc094bfd7a7edc3f4956836 /app-emulation/qemu/qemu-9999.ebuild
parentapp-crypt/sequoia-sq: drop 0.32.0 (diff)
downloadgentoo-d6f20b2493dd5a01308582403e31050b33037508.tar.gz
gentoo-d6f20b2493dd5a01308582403e31050b33037508.tar.bz2
gentoo-d6f20b2493dd5a01308582403e31050b33037508.zip
app-emulation/qemu: Update live ebuild
Because we want to download all dependencies in fetch phase (fixed in [1]), we keep a list of subprojects among with their latest commit hash. Well, in commit [2] qemu bumped 'berkeley-testfloat-3'. Reflect that in our live ebuild. Unfortunately, I've missed this in qemu-8.2.0 timeframe (in which the qemu commit was merged), but there's no real harm as these subprojects are part of dist tar. IOW, it's only live ebuild that needs to fetch subprojects explicitly. Also, some patches don't apply cleanly anymore. Rebase them. Oh, and 'nios2' target was removed [3]. 1: https://github.com/gentoo/gentoo/pull/32684 2: https://gitlab.com/qemu-project/qemu/-/commit/c01196bdddc280ae3710912e98e78f3103155eaf 3: https://gitlab.com/qemu-project/qemu/-/commit/6c3014858c4c0024dd0560f08a6eda0f92f658d6 Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/qemu/qemu-9999.ebuild')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 381a891e0191..12e510eb4cc0 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -31,7 +31,7 @@ if [[ ${PV} == *9999* ]]; then
declare -A SUBPROJECTS=(
[keycodemapdb]="f5772a62ec52591ff6870b7e8ef32482371f22c6"
[berkeley-softfloat-3]="b64af41c3276f97f0e181920400ee056b9c88037"
- [berkeley-testfloat-3]="40619cbb3bf32872df8c53cc457039229428a263"
+ [berkeley-testfloat-3]="e7af9751d9f9fd3b47911f51a5cfd08af256a9ab"
)
for proj in "${!SUBPROJECTS[@]}"; do
@@ -84,7 +84,6 @@ COMMON_TARGETS="
mips64
mips64el
mipsel
- nios2
or1k
ppc
ppc64
@@ -316,11 +315,12 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-8.0.0-disable-keymap.patch
- "${FILESDIR}"/${PN}-7.1.0-capstone-include-path.patch
- "${FILESDIR}"/${PN}-8.1.0-also-build-virtfs-proxy-helper.patch
+ "${FILESDIR}"/${PN}-9.0.0-disable-keymap.patch
+ "${FILESDIR}"/${PN}-9.0.0-capstone-include-path.patch
+ "${FILESDIR}"/${PN}-9.0.0-also-build-virtfs-proxy-helper.patch
"${FILESDIR}"/${PN}-8.1.0-skip-tests.patch
"${FILESDIR}"/${PN}-8.1.0-find-sphinx.patch
+
)
QA_PREBUILT="