summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-25 20:21:47 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-25 20:22:57 -0500
commitb44325280357532c6f61a660d802c7545ef34252 (patch)
tree70da757cab9e8e9ca228890952f6d02fb97e9a46 /app-emulation/open-vm-tools
parentsci-geosciences/grass: bump to 7.0.5 (diff)
downloadgentoo-b44325280357532c6f61a660d802c7545ef34252.tar.gz
gentoo-b44325280357532c6f61a660d802c7545ef34252.tar.bz2
gentoo-b44325280357532c6f61a660d802c7545ef34252.zip
app-emulation/open-vm-tools: fix mount.vmhgfs symlink
https://github.com/vmware/open-vm-tools/pull/66 Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/files/10.1.0-mount.vmhgfs.patch33
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild9
2 files changed, 40 insertions, 2 deletions
diff --git a/app-emulation/open-vm-tools/files/10.1.0-mount.vmhgfs.patch b/app-emulation/open-vm-tools/files/10.1.0-mount.vmhgfs.patch
new file mode 100644
index 000000000000..bff97811771b
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/10.1.0-mount.vmhgfs.patch
@@ -0,0 +1,33 @@
+From 1805ab024b10e8185175de7ce9c9b9db87fd0897 Mon Sep 17 00:00:00 2001
+From: Bernd Zeimetz <bernd@bzed.de>
+Date: Sun, 10 Jan 2016 22:18:04 +0100
+Subject: [PATCH] Fix mount.vmhgfs symlinks if DESTDIR is used
+
+Without this change symlinks in the form of
+sbin/mount.vmhgfs -> /build/open-vm-tools-10.0.5-3227872/debian/open-vm-tools/usr/sbin/mount.vmhgfs
+are being produced, if DESTDIR was uset while running make install.
+---
+ open-vm-tools/hgfsmounter/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/open-vm-tools/hgfsmounter/Makefile.am b/open-vm-tools/hgfsmounter/Makefile.am
+index e48417e..fe70892 100644
+--- a/open-vm-tools/hgfsmounter/Makefile.am
++++ b/open-vm-tools/hgfsmounter/Makefile.am
+@@ -33,14 +33,14 @@ install-exec-hook:
+ mv $(DESTDIR)$(sbindir)/mount.vmhgfs \
+ $(DESTDIR)$(sbindir)/mount_vmhgfs
+ -$(MKDIR_P) $(DESTDIR)/sbin
+- -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
++ -$(LN_S) $(sbindir)/mount_vmhgfs \
+ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
+ uninstall-hook:
+ rm -f $(DESTDIR)$(sbindir)/mount_vmhgfs
+ else
+ install-exec-hook:
+ -$(MKDIR_P) $(DESTDIR)/sbin
+- -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
++ -$(LN_S) $(sbindir)/mount.vmhgfs \
+ $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
+ uninstall-hook:
+ rm -f $(DESTDIR)/sbin/mount.vmhgfs
diff --git a/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild b/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
index 6a3727d42238..3fdaed535ffa 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
@@ -59,6 +59,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}/open-vm-tools"
+PATCHES=(
+ "${FILESDIR}/10.1.0-mount.vmhgfs.patch"
+ "${FILESDIR}/10.1.0-vgauth.patch"
+)
+
pkg_setup() {
linux-info_get_any_version
local CONFIG_CHECK="~VMWARE_BALLOON ~VMWARE_PVSCSI ~VMXNET3"
@@ -73,8 +78,8 @@ pkg_setup() {
}
src_prepare() {
- eapply -p2 "${FILESDIR}/10.1.0-vgauth.patch"
- default
+ eapply -p2 "${PATCHES[@]}"
+ eapply_user
eautoreconf
}