summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-28 15:25:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-28 16:04:59 +0200
commitf7504fdd713ca4d32d6e7b684ded22671e715d25 (patch)
tree29d48d3781f387bf487ece410b5ac08967bec023 /app-emacs
parentapp-emacs/ivy: drop old 0.13.4 (diff)
downloadgentoo-f7504fdd713ca4d32d6e7b684ded22671e715d25.tar.gz
gentoo-f7504fdd713ca4d32d6e7b684ded22671e715d25.tar.bz2
gentoo-f7504fdd713ca4d32d6e7b684ded22671e715d25.zip
app-emacs/ivy: bump to 0.14.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ivy/Manifest1
-rw-r--r--app-emacs/ivy/ivy-0.14.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/ivy/Manifest b/app-emacs/ivy/Manifest
index 45fe46a14f11..41097db74b88 100644
--- a/app-emacs/ivy/Manifest
+++ b/app-emacs/ivy/Manifest
@@ -1 +1,2 @@
DIST swiper-0.14.0.tar.gz 249820 BLAKE2B 9184e66f910b9f7c401c9a5433b5915c393ece7711858c3f844d8afcbc13fa76039173b2ecd50bbaff586ff7596fd95e46e550a4282763e385f064d2e2103978 SHA512 e87fa2159d1541afdaa08e33584480cbeba75df15235bf57d4c8f6292b91be7e2a316e931c3f4d823da5fbf23d987ded293a433824af04357de231d26adfeeb1
+DIST swiper-0.14.2.tar.gz 250059 BLAKE2B 8a5437726c729398a689266d138f271f5f7329f9c58613c4e0cfabd16b99421035c4b522d0ea4c60c0369362cb076bcae05ff4155d33d186172fd0ac2258495d SHA512 e125a3747abc4e6ecc98f539cf5dde11851d6c8a58b8988e165300bce7822fc91257cae09c973bd43435fb08dc24af9a1bd4b3e51083b45654b1605d80973d74
diff --git a/app-emacs/ivy/ivy-0.14.2.ebuild b/app-emacs/ivy/ivy-0.14.2.ebuild
new file mode 100644
index 000000000000..3bedf16037a6
--- /dev/null
+++ b/app-emacs/ivy/ivy-0.14.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Generic completion mechanism for Emacs"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS=( CONTRIBUTING.org README.md doc/{Changelog,ivy-help,ivy}.org )
+SITEFILE="50${PN}-gentoo.el"
+
+# Main Ivy sources. Swiper, Counsel and Ivy extensions have their own packages.
+IVY_SOURCES=( colir.el ivy{,-overlay,-faces}.el )
+
+src_prepare() {
+ elisp_src_prepare
+
+ # Wipe "elpa.el" to prevent initialization of the "package" library.
+ [[ ! -f elpa.el ]] && die "no \"elpa.el\" found"
+ echo "" > elpa.el || die "failed to wipe \"elpa.el\""
+}
+
+src_compile() {
+ elisp-compile ${IVY_SOURCES[@]}
+ emake -C doc ivy.info
+}
+
+src_test() {
+ emake emacs="${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS}" test
+}
+
+src_install() {
+ elisp-install ${PN} ${IVY_SOURCES[@]} *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/ivy.info
+ einstalldocs
+}