summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-11 20:18:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-11 20:21:11 +0200
commitc506a2c68aebc962e014189c5dd4aff5b3b58d32 (patch)
treefe13cf7303a395b5d10e77d0e8f5e8dd492471b0 /app-emacs
parentnet-misc/sunshine: Fix NPM issue by shipping pre-compiled assets (diff)
downloadgentoo-c506a2c68aebc962e014189c5dd4aff5b3b58d32.tar.gz
gentoo-c506a2c68aebc962e014189c5dd4aff5b3b58d32.tar.bz2
gentoo-c506a2c68aebc962e014189c5dd4aff5b3b58d32.zip
app-emacs/editorconfig-emacs: bump to 0.11.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/editorconfig-emacs/Manifest1
-rw-r--r--app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/editorconfig-emacs/Manifest b/app-emacs/editorconfig-emacs/Manifest
index 9030cde0f252..10effe5cbd02 100644
--- a/app-emacs/editorconfig-emacs/Manifest
+++ b/app-emacs/editorconfig-emacs/Manifest
@@ -1 +1,2 @@
DIST editorconfig-emacs-0.10.1.tar.gz 41259 BLAKE2B d03a86413122db05d87af4ea1a51087f22998d362e66965d0a6cd0f67ce57d7e6f15c403745ff018114715c1551f439b54a4c2e7e25325bd436c0959ea1a5595 SHA512 dc254ecf38b0f4b8850ff70f5a1a1ac72cd64e3795f5202d4bc8e13a0d1d9351e816e9a92f809cee6c6404348ba9bd1d908e17c2b0bce15dca112fe9cf1efc2b
+DIST editorconfig-emacs-0.11.0.tar.gz 41902 BLAKE2B 506ddec2dc5c68926a4255694cd3d4b3a97fcf6217774915f3eeb4a85f2665d7259a974e19b1059645b2057c65aecaf9fff5cb2827d8eb82e749cd1b0a7e8841 SHA512 61d96c093a4617488cd0e361bbe9c37b928b26b1e25b87a83e6f49ffeef0832110768a38ea274aa6f960e68b08839d3ace30ec185a94aa5ea478216c0a9f7585
diff --git a/app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild b/app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild
new file mode 100644
index 000000000000..70727ee7d63e
--- /dev/null
+++ b/app-emacs/editorconfig-emacs/editorconfig-emacs-0.11.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="EditorConfig plugin for emacs"
+HOMEPAGE="https://github.com/editorconfig/editorconfig-emacs"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/editorconfig/${PN}.git"
+else
+ SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( CHANGELOG.md README.md )
+DOC_CONTENTS="The EditorConfig feature is not enabled as a site default.
+ Add the following line to your ~/.emacs file to activate it:
+ \n\t(editorconfig-mode 1)"
+
+elisp-enable-tests ert ./ert-tests -l ./ert-tests/editorconfig-core.el