summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:00:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:53 +0100
commit5ddd5373069419a3717657d8b65b95ffb94d32a5 (patch)
tree3c66c11ea0ff1adc6237908ee5202c55401600f4 /app-emacs
parentapp-emacs/consult: drop old 0.35 (diff)
downloadgentoo-5ddd5373069419a3717657d8b65b95ffb94d32a5.tar.gz
gentoo-5ddd5373069419a3717657d8b65b95ffb94d32a5.tar.bz2
gentoo-5ddd5373069419a3717657d8b65b95ffb94d32a5.zip
app-emacs/consult: bump to 1.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 1ca0f03c3158..621bc786e8e6 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1,2 +1,3 @@
DIST consult-1.0.tar.gz 103340 BLAKE2B bb4f31b8145fc490e3413e813ae17b904fae17dc5bb9b8381fea916ff5e49ba2e25ab41f5a6711a7bebae8a0a7e5074d1274482d89dd1818c872bc0c1860db78 SHA512 354486706863ed7bd9e6445afeb777a2b1dc9ae805c0cb20ed9f0f501cde5fa6e10800ae0f036c46121920c7b0c1a4733c2e97f8138166bc0d84c31f711d6f10
DIST consult-1.1.tar.gz 103352 BLAKE2B 8ad8eff3d65013de40f9ee10abaa6ea39acb6b96543d533bc4a272139778445863d26d06a88a759215ee46a95cc68595e8b3eb4e91db911b6b6f104e97a47cce SHA512 687266605f2b8fa9260362aabacd8508acb5239fa72061efbc002d311cf5ebef6fce8795729ab3fc2915de3455e1744dc9980dba422495340349e8c426c44a28
+DIST consult-1.2.tar.gz 103598 BLAKE2B 684ac2c9aca7901ee7ad2d2601327ff57c9fe08b20c6314526b1166bec0276bdf129bd80d09a54b15a1cf91030ed7d2377d91ed49d8ba4e177e3438264587302 SHA512 f8c927bbe447b9337faa511bec59188198d2a6ee0acd142bd48603f09634b7219e183c509245fa7026145c3ca688a6ab152fc0ededc0bf81ee3fb019ef1d675f
diff --git a/app-emacs/consult/consult-1.2.ebuild b/app-emacs/consult/consult-1.2.ebuild
new file mode 100644
index 000000000000..e1f29886c2e1
--- /dev/null
+++ b/app-emacs/consult/consult-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}