summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-15 19:46:04 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-15 19:48:59 +0100
commit270404c94829b155109adfef09780888694f8631 (patch)
tree7e28130c314e0b6e236a82f5166aab2f05b3a252 /app-emacs
parentapp-emacs/adaptive-wrap: Version bump to 0.8 (diff)
downloadgentoo-270404c94829b155109adfef09780888694f8631.tar.gz
gentoo-270404c94829b155109adfef09780888694f8631.tar.bz2
gentoo-270404c94829b155109adfef09780888694f8631.zip
app-emacs/async: Version bump to 1.9.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/async/Manifest1
-rw-r--r--app-emacs/async/async-1.9.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/async/Manifest b/app-emacs/async/Manifest
index 6355cabf490c..fe031c1e4189 100644
--- a/app-emacs/async/Manifest
+++ b/app-emacs/async/Manifest
@@ -1 +1,2 @@
DIST emacs-async-1.9.3.tar.gz 14394 BLAKE2B dd6a98e61027dae2fa9ebb8e20f81a2d2debff1e990e57084a747ea815d1e615dc0e4b8fe5fcdc1f562c0f02780951121f4a67b26584f4519290413da05dc1e9 SHA512 ecbbb6614882df8a58a3440a78867e6cd19ae448e2e897b27d6aeaf5e5a648dcedbac64afbfd6240b7e68c533c685060f453051ef9a85d9d4cca6831fbf2c1dd
+DIST emacs-async-1.9.4.tar.gz 15375 BLAKE2B 763c716672722e8d8ba2b1d351513ab545826214a475b155ef79b741cfd69ef02e579ccd10a09acfee712713e4f60ae746a509fa487ed464c4706baa17011a8f SHA512 ca225588868320485f886b7fced526bce951dac19319bdfe9c17e74c68c2e5cb624e324842025fdc8d94affe9d10bf44c86132b5e762593a9204a804eac43d2b
diff --git a/app-emacs/async/async-1.9.4.ebuild b/app-emacs/async/async-1.9.4.ebuild
new file mode 100644
index 000000000000..45b0c0da522d
--- /dev/null
+++ b/app-emacs/async/async-1.9.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}