summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-10 17:26:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-10 20:16:33 +0200
commit069dc1671187439c93b86723579a2289503de95d (patch)
tree73e5919ac8fa1cb1a57787dfe834c6ad77571d34 /app-emacs
parentapp-emacs/git-modes: drop old 1.4.2 (diff)
downloadgentoo-069dc1671187439c93b86723579a2289503de95d.tar.gz
gentoo-069dc1671187439c93b86723579a2289503de95d.tar.bz2
gentoo-069dc1671187439c93b86723579a2289503de95d.zip
app-emacs/git-modes: bump to 1.4.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/git-modes/Manifest1
-rw-r--r--app-emacs/git-modes/git-modes-1.4.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/git-modes/Manifest b/app-emacs/git-modes/Manifest
index b6ddd1fbed5d..e2af142eeb8f 100644
--- a/app-emacs/git-modes/Manifest
+++ b/app-emacs/git-modes/Manifest
@@ -1 +1,2 @@
DIST git-modes-1.4.3.tar.gz 18487 BLAKE2B 2df138576b6eeb628e88bf6f7649f42897d852f89d7d9ab0febc26db0f5c71cc0412ddb511f93b7ce32e444f085747e8f66eabeba5a0182bbe2ff99be3b4b6ed SHA512 0f96e3259ef9c17249f0960c8495043e8b0e2769cdf3b0572e72f83fdecd469403561a4c2666323d0f8d8a3059b8785443662e260881699e0b93e76b3a9e0474
+DIST git-modes-1.4.4.tar.gz 18483 BLAKE2B 031635fd4bdc457456ddfb518be5f676f4be8b369b69b966b6b25b61e781ef0484592fec84be0df67c5d3087169336a3271b9f95fe8a1091d271c77e1f07c4fe SHA512 4959efb71f0321a2964e4a768fdcbbcbc668517b699b5a4f8416f6df3dd7322f69cd0d1fb306a0fd7221a369f17d042d3670cea57655b39f60a1f78e0a5ab7ed
diff --git a/app-emacs/git-modes/git-modes-1.4.4.ebuild b/app-emacs/git-modes/git-modes-1.4.4.ebuild
new file mode 100644
index 000000000000..cbe21880ac81
--- /dev/null
+++ b/app-emacs/git-modes/git-modes-1.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs major modes for editing Git configuration files"
+HOMEPAGE="https://github.com/magit/git-modes/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}