summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-04 22:50:26 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-04 22:57:03 +0100
commitaafaa9b3526cc4ba43c43da11e5e8fd09e03d471 (patch)
tree9e3dfa17616f79154e9d21584acbaaced7358608 /app-emacs/webpaste
parentapp-containers/devcontainer: bump to 0.57.0 (diff)
downloadgentoo-aafaa9b3526cc4ba43c43da11e5e8fd09e03d471.tar.gz
gentoo-aafaa9b3526cc4ba43c43da11e5e8fd09e03d471.tar.bz2
gentoo-aafaa9b3526cc4ba43c43da11e5e8fd09e03d471.zip
app-emacs/webpaste: modernize ebuild
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/webpaste')
-rw-r--r--app-emacs/webpaste/webpaste-3.2.2-r1.ebuild45
-rw-r--r--app-emacs/webpaste/webpaste-3.2.2.ebuild32
2 files changed, 45 insertions, 32 deletions
diff --git a/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild b/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..27a00d8097bc
--- /dev/null
+++ b/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Paste parts of buffers to several pastebin-like services from Emacs"
+HOMEPAGE="https://github.com/etu/webpaste.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/etu/${PN}.el.git"
+else
+ SRC_URI="https://github.com/etu/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el-${PV}"
+
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/request
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/undercover
+ )
+"
+
+# Remove failing tests
+ELISP_REMOVE="
+ tests/integration/test-webpaste-providers.el
+ tests/unit/test-webpaste-provider-creation.el
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup tests
diff --git a/app-emacs/webpaste/webpaste-3.2.2.ebuild b/app-emacs/webpaste/webpaste-3.2.2.ebuild
deleted file mode 100644
index caedce2d6403..000000000000
--- a/app-emacs/webpaste/webpaste-3.2.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp
-
-DESCRIPTION="Paste parts of buffers to several pastebin-like services from Emacs"
-HOMEPAGE="https://github.com/etu/webpaste.el/"
-SRC_URI="https://github.com/etu/${PN}.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}.el-${PV}
-
-LICENSE="GPL-3+"
-KEYWORDS="amd64 ~x86"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-emacs/request"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/buttercup )
-"
-
-DOCS=( README.org )
-# Remove failing tests
-ELISP_REMOVE="tests/unit/test-webpaste-provider-creation.el"
-SITEFILE="50${PN}-gentoo.el"
-
-src_test() {
- buttercup -L . -L tests tests/unit || die
-}