summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/sumibi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/sumibi')
-rw-r--r--app-emacs/sumibi/Manifest1
-rw-r--r--app-emacs/sumibi/files/50sumibi-gentoo.el4
-rw-r--r--app-emacs/sumibi/metadata.xml9
-rw-r--r--app-emacs/sumibi/sumibi-0.5.2.ebuild31
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/sumibi/Manifest b/app-emacs/sumibi/Manifest
new file mode 100644
index 000000000000..98f41a4334d6
--- /dev/null
+++ b/app-emacs/sumibi/Manifest
@@ -0,0 +1 @@
+DIST sumibi-0.5.2.tar.gz 26755 SHA256 345d956a537f56f36139e679e61f18c316908f92d21e31ad5042a92466066fbc SHA512 b630be8b7c73ba5e0babc2c2946ddb05019fa15b0a8aaf5b578c97de32094de174d6ced9c0168b2e802e35e2b30b4a02501a0d8c41b90a8f8bb4a85fe501cff3 WHIRLPOOL eecee77c92267178da091433158d3f991b9aaa42160589b209d4ef3a945a5eabf6434c4fccb9d8e6aa8ce8cef03fbc4f73654d183d64aa39b1716c8d88739fdd
diff --git a/app-emacs/sumibi/files/50sumibi-gentoo.el b/app-emacs/sumibi/files/50sumibi-gentoo.el
new file mode 100644
index 000000000000..e0292e2481bf
--- /dev/null
+++ b/app-emacs/sumibi/files/50sumibi-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; sumibi site-lisp configuration
+
+(require 'sumibi)
diff --git a/app-emacs/sumibi/metadata.xml b/app-emacs/sumibi/metadata.xml
new file mode 100644
index 000000000000..ccebeb74e563
--- /dev/null
+++ b/app-emacs/sumibi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge-jp">sumibi</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/sumibi/sumibi-0.5.2.ebuild b/app-emacs/sumibi/sumibi-0.5.2.ebuild
new file mode 100644
index 000000000000..55cc47f94b39
--- /dev/null
+++ b/app-emacs/sumibi/sumibi-0.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+DESCRIPTION="Statistical Japanese input method using the Internet as a large corpus"
+HOMEPAGE="http://www.sumibi.org/"
+SRC_URI="mirror://sourceforge.jp/sumibi/17176/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ cd client/elisp
+ elisp-compile *.el || die "elisp-compile failed"
+}
+
+src_install() {
+ cd client/elisp
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+
+ cd "${S}"
+ dodoc README CREDITS CHANGELOG
+}