summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-16 18:22:01 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-16 18:38:38 +0100
commit827e9d7d24e1177595f35c7897a7850fb92d963d (patch)
tree3da38b22ff91ec28fb48d94048097db52ad38e59 /app-emacs/rudel/rudel-0.3.2.ebuild
parentapp-emacs/popwin: Version bump to 1.0.2 (diff)
downloadgentoo-827e9d7d24e1177595f35c7897a7850fb92d963d.tar.gz
gentoo-827e9d7d24e1177595f35c7897a7850fb92d963d.tar.bz2
gentoo-827e9d7d24e1177595f35c7897a7850fb92d963d.zip
app-emacs/rudel: Version bump to 0.3.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/rudel/rudel-0.3.2.ebuild')
-rw-r--r--app-emacs/rudel/rudel-0.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/rudel/rudel-0.3.2.ebuild b/app-emacs/rudel/rudel-0.3.2.ebuild
new file mode 100644
index 000000000000..58aeb89e675a
--- /dev/null
+++ b/app-emacs/rudel/rudel-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Collaborative editing environment for GNU Emacs"
+HOMEPAGE="http://rudel.sourceforge.net/
+ https://www.emacswiki.org/emacs/Rudel"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz" # from GNU ELPA
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ELISP_REMOVE="${PN}-pkg.el"
+SITEFILE="60${PN}-gentoo-0.3.1.el"
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+
+ dodoc README INSTALL ChangeLog TODO doc/card.pdf
+
+ DOC_CONTENTS="Connections to Gobby servers require the gnutls-cli program
+ (net-libs/gnutls[tools]).
+ \\n\\nThe Avahi daemon (net-dns/avahi) is required for automatic
+ session discovery and advertising."
+ readme.gentoo_create_doc
+}