summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-16 18:58:22 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-16 18:58:50 +0200
commit9c97c4736da82746a53d21840cda5de48bd7f294 (patch)
tree2b8e8914aec4c56316a6c6b7e834d9b70d28d4ee /app-emacs/psgml/psgml-1.4.1.ebuild
parentapp-emacs/pymacs: Bump to version 0.26. (diff)
downloadgentoo-9c97c4736da82746a53d21840cda5de48bd7f294.tar.gz
gentoo-9c97c4736da82746a53d21840cda5de48bd7f294.tar.bz2
gentoo-9c97c4736da82746a53d21840cda5de48bd7f294.zip
app-emacs/psgml: Bump to version 1.4.1.
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/psgml/psgml-1.4.1.ebuild')
-rw-r--r--app-emacs/psgml/psgml-1.4.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/psgml/psgml-1.4.1.ebuild b/app-emacs/psgml/psgml-1.4.1.ebuild
new file mode 100644
index 000000000000..465c0edee1d9
--- /dev/null
+++ b/app-emacs/psgml/psgml-1.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
+HOMEPAGE="https://www.emacswiki.org/emacs/PsgmlMode"
+# taken from https://marmalade-repo.org/packages/${P}.tar
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-text/openjade"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins *.map
+ doinfo psgml.info psgml-api.info
+ dodoc ChangeLog INSTALL README.psgml psgml.ps
+}