summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-16 23:42:29 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-16 23:42:29 +0100
commitb715ce641864362e1faccc38abb12d9a7c0d637d (patch)
tree2cf19de017a4526839a8967d87323daa84fe9e01 /app-emacs/powerline
parentprofiles: add aarch64_be systemd profiles (diff)
downloadgentoo-b715ce641864362e1faccc38abb12d9a7c0d637d.tar.gz
gentoo-b715ce641864362e1faccc38abb12d9a7c0d637d.tar.bz2
gentoo-b715ce641864362e1faccc38abb12d9a7c0d637d.zip
app-emacs/powerline: new package; add 2.5_p20221110
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/powerline')
-rw-r--r--app-emacs/powerline/Manifest1
-rw-r--r--app-emacs/powerline/files/50powerline-gentoo.el2
-rw-r--r--app-emacs/powerline/metadata.xml21
-rw-r--r--app-emacs/powerline/powerline-2.5_p20221110.ebuild26
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/powerline/Manifest b/app-emacs/powerline/Manifest
new file mode 100644
index 000000000000..de26a4195700
--- /dev/null
+++ b/app-emacs/powerline/Manifest
@@ -0,0 +1 @@
+DIST powerline-2.5_p20221110.tar.gz 25649 BLAKE2B 9ffe42a0edbe620a77272636ed7426dcfb35388a20dcbe7905a95a6e0971d4e249ffc4af70061e61fdb4ea98fcef982d7da7617e81f5db0e2df425dfe31ea097 SHA512 be0eedd1b79e37b80f0520706af11b36d0775aced51f08239d240fc19c1c54124bc736009cb2eb1332b9a9a064221885dcaebfac5595211afe9939409256d92b
diff --git a/app-emacs/powerline/files/50powerline-gentoo.el b/app-emacs/powerline/files/50powerline-gentoo.el
new file mode 100644
index 000000000000..bc3d2514cd23
--- /dev/null
+++ b/app-emacs/powerline/files/50powerline-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "powerline-autoloads" nil t)
diff --git a/app-emacs/powerline/metadata.xml b/app-emacs/powerline/metadata.xml
new file mode 100644
index 000000000000..9565b18c1a6e
--- /dev/null
+++ b/app-emacs/powerline/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Powerline is a library for customizing the mode-line that is based on the
+ Vim Powerline. A collection of predefined themes comes with the package.
+ This version has utf-8 support enabled. The utf-8 separators will display a
+ unicode character properly under mintty for example - as long as you have
+ patched fonts installed. By default, any terminal mode emacs will use the
+ utf-8 separators.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/milkypostman/powerline/issues/</bugs-to>
+ <remote-id type="github">milkypostman/powerline</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/powerline/powerline-2.5_p20221110.ebuild b/app-emacs/powerline/powerline-2.5_p20221110.ebuild
new file mode 100644
index 000000000000..f1e953e1fbb1
--- /dev/null
+++ b/app-emacs/powerline/powerline-2.5_p20221110.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ ${PV} = *_p20221110 ]] && H=c35c35bdf5ce2d992882c1f06f0f078058870d4a
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs version of the Vim powerline"
+HOMEPAGE="https://github.com/milkypostman/powerline/"
+SRC_URI="https://github.com/milkypostman/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}