summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-13 18:24:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-13 22:57:02 +0200
commitee6e6db55fa57c6ac26d9828ea133c50570aedc4 (patch)
tree525a8993545a46ce6c8d7d33f00f26404b80d4b5 /app-emacs/persist
parentapp-emacs/plz: bump to 0.9.1 (diff)
downloadgentoo-ee6e6db55fa57c6ac26d9828ea133c50570aedc4.tar.gz
gentoo-ee6e6db55fa57c6ac26d9828ea133c50570aedc4.tar.bz2
gentoo-ee6e6db55fa57c6ac26d9828ea133c50570aedc4.zip
app-emacs/persist: bump to 0.6.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/persist')
-rw-r--r--app-emacs/persist/Manifest1
-rw-r--r--app-emacs/persist/persist-0.6.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/persist/Manifest b/app-emacs/persist/Manifest
index d5b23a1f20b1..f5f44c5240f8 100644
--- a/app-emacs/persist/Manifest
+++ b/app-emacs/persist/Manifest
@@ -1 +1,2 @@
+DIST persist-0.6.1.tar.gz 6777 BLAKE2B 4e5ae7cef591fcfb7fd7084e38294bc6000d9b1ed2d9b83ea54c1f6fe4f4cbb4144df51a5df9fcc654d459c58e105e58c53cfe841df0eeeafd95ed127797cb2d SHA512 e7b2d2e09cea26a37142d66e95f640e37640ebcf8434b284650c6126475c8844476c164b00ffc3cbecb021bb6963a19ede2720ae2e892d45d8986ede6de3f28a
DIST persist-0.6.tar.xz 5852 BLAKE2B 4cee1485109e3215ce739c0c286e2076c19cf86eb23305adc9203f40ac1d08ed1de19def3ffe4361d062bae75ba38ef380636bbf5fbe58f4aa7127771198e378 SHA512 280a1a26a61f1ee7b1e2186917e7b414b14886ef32fa1b63c0416267991ae65f5c46feaaa384a6c15d2f7975841a6bb9901353420db4d6f308cf72c5035bfd66
diff --git a/app-emacs/persist/persist-0.6.1.ebuild b/app-emacs/persist/persist-0.6.1.ebuild
new file mode 100644
index 000000000000..8f745ad5237e
--- /dev/null
+++ b/app-emacs/persist/persist-0.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == "0.6.1" ]] && COMMIT="5ea8f32ef50ce2b444d6918e17eedce9f74629af"
+
+inherit elisp
+
+DESCRIPTION="Persist variables between Emacs sessions"
+HOMEPAGE="https://elpa.gnu.org/packages/persist.html"
+SRC_URI="https://git.savannah.gnu.org/gitweb/?p=emacs/elpa.git;a=snapshot;h=${COMMIT};sf=tgz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/elpa-${COMMIT:0:7}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# ELISP_TEXINFO="${PN}.texi" # Broken.
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert test -l test/persist-tests.el
+
+src_prepare() {
+ default
+
+ # Skip failing tests. Tests are marked as "WORK IN PROGRESS" at the
+ # top of the file.
+ local -a skip_tests=(
+ test-persist-save-hash
+ )
+ local skip_test=""
+ for skip_test in "${skip_tests[@]}"; do
+ sed -i "/${skip_test}/a (ert-skip nil)" test/persist-tests.el || die
+ done
+}