summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-12 12:26:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-12 12:26:25 +0100
commitc50bd9f66c36ccfba27f323126b4f569af1bc0cc (patch)
tree3717fe70331b7d555ec8949e9b1ae2a3394fc8c7 /app-emacs/parseclj
parentapp-emacs/sesman: new package; add 0.3.4 (diff)
downloadgentoo-c50bd9f66c36ccfba27f323126b4f569af1bc0cc.tar.gz
gentoo-c50bd9f66c36ccfba27f323126b4f569af1bc0cc.tar.bz2
gentoo-c50bd9f66c36ccfba27f323126b4f569af1bc0cc.zip
app-emacs/parseclj: new package; add 1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/parseclj')
-rw-r--r--app-emacs/parseclj/Manifest1
-rw-r--r--app-emacs/parseclj/files/50parseclj-gentoo.el1
-rw-r--r--app-emacs/parseclj/metadata.xml18
-rw-r--r--app-emacs/parseclj/parseclj-1.1.0.ebuild28
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/parseclj/Manifest b/app-emacs/parseclj/Manifest
new file mode 100644
index 000000000000..4debc08efab7
--- /dev/null
+++ b/app-emacs/parseclj/Manifest
@@ -0,0 +1 @@
+DIST parseclj-1.1.0.tar.gz 37228 BLAKE2B d0e74eeb3a1ea9cec7445f3e2627d8d6287ff476fdff4a1dd9b3f58100621a02fc0f0369b96bd92fa8f43485d8c45ffa0a7d41681dfe71020157ca467325e2b9 SHA512 ef8da1f65d4f873c81a785aae495128dc551b73cc89cda7c8b37ce8be15b7473c6cbcd886d5ea285ae414a05a02109b60a8cd933720f1a4b6a1e63e07ec33cf8
diff --git a/app-emacs/parseclj/files/50parseclj-gentoo.el b/app-emacs/parseclj/files/50parseclj-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parseclj/files/50parseclj-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parseclj/metadata.xml b/app-emacs/parseclj/metadata.xml
new file mode 100644
index 000000000000..c7ad27b76ae9
--- /dev/null
+++ b/app-emacs/parseclj/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ parseclj is an Emacs Lisp library for parsing Clojure code and EDN data. It
+ supports several input and output formats, all powered by the same
+ shift-reduce parser function.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/parseclj/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/parseclj</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseclj/parseclj-1.1.0.ebuild b/app-emacs/parseclj/parseclj-1.1.0.ebuild
new file mode 100644
index 000000000000..0adbdc6b45d8
--- /dev/null
+++ b/app-emacs/parseclj/parseclj-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Clojure Parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseclj/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md DESIGN.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}