summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-19 13:04:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-19 14:32:46 +0200
commit4dfe0887fe5127ee8042f0394a3c5e4c193adea1 (patch)
tree0c5cd8ab0e06fe34a9bad3dfb1ee385fc0ad3c5c /app-emacs/hl-todo/hl-todo-3.7.0.ebuild
parentapp-emacs/hl-todo: drop old 3.5.0 (diff)
downloadgentoo-4dfe0887fe5127ee8042f0394a3c5e4c193adea1.tar.gz
gentoo-4dfe0887fe5127ee8042f0394a3c5e4c193adea1.tar.bz2
gentoo-4dfe0887fe5127ee8042f0394a3c5e4c193adea1.zip
app-emacs/hl-todo: bump to 3.7.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/hl-todo/hl-todo-3.7.0.ebuild')
-rw-r--r--app-emacs/hl-todo/hl-todo-3.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/hl-todo/hl-todo-3.7.0.ebuild b/app-emacs/hl-todo/hl-todo-3.7.0.ebuild
new file mode 100644
index 000000000000..50a91455193c
--- /dev/null
+++ b/app-emacs/hl-todo/hl-todo-3.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highlight TODO and similar keywords in comments and strings"
+HOMEPAGE="https://github.com/tarsius/hl-todo/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/tarsius/${PN}.git"
+else
+ SRC_URI="https://github.com/tarsius/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.5
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"