summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-13 16:19:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-13 20:31:14 +0200
commitbdc5b0123d3625768f47a2509cbb3d7f36205d2a (patch)
tree3ac517b0f103e86ee143d49d633e1b7b43c02c41 /app-emacs/helm
parentapp-emacs/helm: drop old 3.9.1 (diff)
downloadgentoo-bdc5b0123d3625768f47a2509cbb3d7f36205d2a.tar.gz
gentoo-bdc5b0123d3625768f47a2509cbb3d7f36205d2a.tar.bz2
gentoo-bdc5b0123d3625768f47a2509cbb3d7f36205d2a.zip
app-emacs/helm: bump to 3.9.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.9.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index ce1beac37649..f55cce1d9c48 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,2 +1,3 @@
DIST helm-3.9.3.tar.gz 2373295 BLAKE2B ff34d5a68a1e25571c734185a37843d958b859096c22ca0222b64fb684a6de607d11b08f7beaa618f0017126c744f7f12dfe9d3ea03757874e485f4bdb5c2fc8 SHA512 4c1cce5eb93f89f388fb5da6a813f819867db6bc965ca378a788eaa5bf17c577b20034be9df57691737662d34809da4d86532b8b98765d6f102f84ee2169e80b
DIST helm-3.9.4.tar.gz 2372828 BLAKE2B a1ca18531dcb1887d5a12b3536b05d68d6d40c7a41b9d3bd25f3cd286ccbd217bc45843007e208e84eafd5e3b4106d32461df87dd57d1a78d0a89f58cf933730 SHA512 17d5a99ea85481f7d4b9bea9fff2a602b0a824ad4f050b26e0225ec8e18025e6307434d4de31120786d3498f937a854ef4a080103df025be6a0e4718e7dd9161
+DIST helm-3.9.5.tar.gz 2374812 BLAKE2B 6d2428297faa15fff4b07ddc857e89ddc1aa0a6c5a3eb0f96fecff1b01259050c597b43222b169dfbdb86fabe7cbe0094b829bc3dbca42736139a0ec03846176 SHA512 0096580abcf6ac4e9f20cd56a9390b8234c5d08786b13e2d4428568a0412508bb6b0820c88c0a3ceec34495d1c4514166d201986a3b0967ef2a2735d471a94e3
diff --git a/app-emacs/helm/helm-3.9.5.ebuild b/app-emacs/helm/helm-3.9.5.ebuild
new file mode 100644
index 000000000000..76671b3b26bc
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.8.8-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}