summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/emacs-w3m
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/emacs-w3m')
-rw-r--r--app-emacs/emacs-w3m/Manifest2
-rw-r--r--app-emacs/emacs-w3m/emacs-w3m-1.4.513_pre20130204.ebuild53
-rw-r--r--app-emacs/emacs-w3m/emacs-w3m-1.4.528_pre20140213.ebuild49
-rw-r--r--app-emacs/emacs-w3m/files/70emacs-w3m-gentoo.el3
-rw-r--r--app-emacs/emacs-w3m/metadata.xml5
5 files changed, 112 insertions, 0 deletions
diff --git a/app-emacs/emacs-w3m/Manifest b/app-emacs/emacs-w3m/Manifest
new file mode 100644
index 000000000000..ac397554868b
--- /dev/null
+++ b/app-emacs/emacs-w3m/Manifest
@@ -0,0 +1,2 @@
+DIST emacs-w3m-1.4.513_pre20130204.tar.xz 724892 SHA256 fc71922e8a5249584075a86bb274f08f193d82ed2e29786dcdfac4049b6b8873 SHA512 86d5aadd4a3e667a5f940ac47bd7c828546260dc6026bd3a906c5439ed07c702019e7dc7c4eac1bc2f4d3a9a6e03e28b59f3c48ce649c644d6608a120a67dfc0 WHIRLPOOL b4e7bd2809f6518f5b96fdc11c491ebe25169aef07613e443b6d293cedc3195f4789d31c2bea3e5648073087ecad66dd25175858f78e7307dcc37fb7fc5f526a
+DIST emacs-w3m-1.4.528_pre20140213.tar.xz 751532 SHA256 0be76617be14532493f95c1bb01b4c7337aa0407c5effe58d32feb9bd2b30f7f SHA512 f4ccb41f2011354c091c9b07b2ab596f030a6b2e8ef2ef674db75c93e5bfe7347b8b3602283e169e7fd591c44b222482d1a399880c60176fc55a5e77ed728483 WHIRLPOOL e3c838c1d65735899f74e09ed5362bc93e79564cb8c5076cf2dcd77880dd9d72afb7c3ddc2f9d60a49f1bda1766a6235ae702c368878e654d890127f6d0e445c
diff --git a/app-emacs/emacs-w3m/emacs-w3m-1.4.513_pre20130204.ebuild b/app-emacs/emacs-w3m/emacs-w3m-1.4.513_pre20130204.ebuild
new file mode 100644
index 000000000000..730e25f081da
--- /dev/null
+++ b/app-emacs/emacs-w3m/emacs-w3m-1.4.513_pre20130204.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp autotools
+
+DESCRIPTION="emacs-w3m is an interface program of w3m on Emacs"
+HOMEPAGE="http://emacs-w3m.namazu.org/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="linguas_ja"
+
+DEPEND="virtual/w3m"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ emake all-en $(use linguas_ja && echo all-ja)
+}
+
+src_install() {
+ emake lispdir="${ED}${SITELISP}/${PN}" \
+ infodir="${ED}/usr/share/info" \
+ ICONDIR="${ED}${SITEETC}/${PN}" \
+ install-en $(use linguas_ja && echo install-ja) install-icons
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog* NEWS README
+ use linguas_ja && dodoc BUGS.ja NEWS.ja README.ja
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${EPREFIX}/usr/share/doc/${PF}/README*"
+ einfo
+ elog "If you want to use the shimbun library, please emerge app-emacs/apel"
+ elog "and app-emacs/flim."
+}
diff --git a/app-emacs/emacs-w3m/emacs-w3m-1.4.528_pre20140213.ebuild b/app-emacs/emacs-w3m/emacs-w3m-1.4.528_pre20140213.ebuild
new file mode 100644
index 000000000000..80f4535b3485
--- /dev/null
+++ b/app-emacs/emacs-w3m/emacs-w3m-1.4.528_pre20140213.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp autotools
+
+DESCRIPTION="emacs-w3m is an interface program of w3m on Emacs"
+HOMEPAGE="http://emacs-w3m.namazu.org/"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="linguas_ja"
+
+DEPEND="virtual/w3m"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ emake all-en $(use linguas_ja && echo all-ja)
+}
+
+src_install() {
+ emake lispdir="${ED}${SITELISP}/${PN}" \
+ infodir="${ED}/usr/share/info" \
+ ICONDIR="${ED}${SITEETC}/${PN}" \
+ install-en $(use linguas_ja && echo install-ja) install-icons
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog* NEWS README
+ use linguas_ja && dodoc BUGS.ja NEWS.ja README.ja
+
+ DOC_CONTENTS="If you want to use the shimbun library, please emerge
+ app-emacs/apel and app-emacs/flim."
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/emacs-w3m/files/70emacs-w3m-gentoo.el b/app-emacs/emacs-w3m/files/70emacs-w3m-gentoo.el
new file mode 100644
index 000000000000..2f97e134da2d
--- /dev/null
+++ b/app-emacs/emacs-w3m/files/70emacs-w3m-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(setq w3m-icon-directory "@SITEETC@")
+(require 'w3m-load)
diff --git a/app-emacs/emacs-w3m/metadata.xml b/app-emacs/emacs-w3m/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/emacs-w3m/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>