summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-04 09:20:33 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-04 09:43:27 +0100
commiteae884c250aa221846c940d6d133711dc2ea837f (patch)
treedbeb107fcb98167adff4f81ec9d03dd4a3316cbd /app-emacs/consult
parentapp-emacs/consult: drop old 0.34 (diff)
downloadgentoo-eae884c250aa221846c940d6d133711dc2ea837f.tar.gz
gentoo-eae884c250aa221846c940d6d133711dc2ea837f.tar.bz2
gentoo-eae884c250aa221846c940d6d133711dc2ea837f.zip
app-emacs/consult: bump to 1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/consult')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 8af8cdf4335a..00b1089ff380 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1 +1,2 @@
DIST consult-0.35.tar.gz 103472 BLAKE2B 5e47d40bd67811f40ef27f67b508d0fabdbc3bd552ee990e9418b59eedcebfb69241dfeae4a9f084514fc4eb102e17ab7efa4c4e80020d2cd8cd1cd80447aa13 SHA512 a2ee01c970bddd8367c8fe3094483bd5710f1bdbfd3b278e26d443ec42e91dee64b583272ac37e52f198f75554c95f97cd774b7f85b1a1c0d28b9a3905c77721
+DIST consult-1.0.tar.gz 103340 BLAKE2B bb4f31b8145fc490e3413e813ae17b904fae17dc5bb9b8381fea916ff5e49ba2e25ab41f5a6711a7bebae8a0a7e5074d1274482d89dd1818c872bc0c1860db78 SHA512 354486706863ed7bd9e6445afeb777a2b1dc9ae805c0cb20ed9f0f501cde5fa6e10800ae0f036c46121920c7b0c1a4733c2e97f8138166bc0d84c31f711d6f10
diff --git a/app-emacs/consult/consult-1.0.ebuild b/app-emacs/consult/consult-1.0.ebuild
new file mode 100644
index 000000000000..7b1398601c9b
--- /dev/null
+++ b/app-emacs/consult/consult-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}