summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-23 13:47:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-23 13:49:25 +0200
commitfe07b4b07e3e65f0348bd3bb8af5ef6151a97854 (patch)
tree5eaab30d9f19821dbac03d9b3fd42b76c5f643fc /app-editors/qxmledit
parentapp-doc/zsh-lovers: Stabilize 0.10.1 ALLARCHES, #925306 (diff)
downloadgentoo-fe07b4b07e3e65f0348bd3bb8af5ef6151a97854.tar.gz
gentoo-fe07b4b07e3e65f0348bd3bb8af5ef6151a97854.tar.bz2
gentoo-fe07b4b07e3e65f0348bd3bb8af5ef6151a97854.zip
app-editors/qxmledit: fix -Werror
The way we need to pass anto Werror changed, and I missed it when bumping. We can do it now using an environment variable, which is nicer than `sed` command. No revbump, since it affect compilation itself only (failing if there were warnings). Closes: https://bugs.gentoo.org/925324 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/qxmledit-0.9.18-r1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/app-editors/qxmledit/qxmledit-0.9.18-r1.ebuild b/app-editors/qxmledit/qxmledit-0.9.18-r1.ebuild
index 991f54019207..ee4baa01ebfb 100644
--- a/app-editors/qxmledit/qxmledit-0.9.18-r1.ebuild
+++ b/app-editors/qxmledit/qxmledit-0.9.18-r1.ebuild
@@ -35,14 +35,6 @@ BDEPEND="dev-qt/linguist-tools:5"
DOCS=( AUTHORS NEWS README )
-src_prepare() {
- default
-
- # bug 568746
- sed -i -e '/QMAKE_CXXFLAGS/s:-Werror::' \
- src/{QXmlEdit,QXmlEditWidget,sessions/QXmlEditSessions}.pro || die
-}
-
src_configure() {
export \
QXMLEDIT_INST_DIR="${EPREFIX}/usr/bin" \
@@ -51,6 +43,9 @@ src_configure() {
QXMLEDIT_INST_DATA_DIR="${EPREFIX}/usr/share/${PN}" \
QXMLEDIT_INST_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ # avoid -Werror (affecting src/coptions.pri) bug #925324
+ export QXMLEDIT_INST_DISABLE_COMPILE_WARNINGS=Y
+
# avoid internal compiler errors
use x86 && export QXMLEDIT_INST_AVOID_PRECOMP_HEADERS=Y