summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-05 12:17:06 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-05 12:18:38 +0100
commit2f29e0b92f09adf5af6d493a4033491e51b99ec4 (patch)
tree39707f408e0c98635fa9c11219d7fa484f1cee3c /app-editors/neovim
parentapp-editors/neovim: version bump. (diff)
downloadgentoo-2f29e0b92f09adf5af6d493a4033491e51b99ec4.tar.gz
gentoo-2f29e0b92f09adf5af6d493a4033491e51b99ec4.tar.bz2
gentoo-2f29e0b92f09adf5af6d493a4033491e51b99ec4.zip
app-editors/neovim: add missing dev-util/gperf dependency.
Closes: https://bugs.gentoo.org/628258 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/neovim-0.2.0.ebuild14
-rw-r--r--app-editors/neovim/neovim-9999.ebuild14
2 files changed, 18 insertions, 10 deletions
diff --git a/app-editors/neovim/neovim-0.2.0.ebuild b/app-editors/neovim/neovim-0.2.0.ebuild
index dace3d4ec43a..a37942870e06 100644
--- a/app-editors/neovim/neovim-0.2.0.ebuild
+++ b/app-editors/neovim/neovim-0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,12 +32,16 @@ CDEPEND=">=dev-libs/libuv-1.2.0
dev-libs/libvterm
dev-lua/lpeg[luajit=]
dev-lua/mpack[luajit=]
- jemalloc? ( dev-libs/jemalloc )
-"
-DEPEND="${CDEPEND}
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
virtual/libiconv
virtual/libintl"
-RDEPEND="${CDEPEND}
+
+RDEPEND="
+ ${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index dace3d4ec43a..a37942870e06 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,12 +32,16 @@ CDEPEND=">=dev-libs/libuv-1.2.0
dev-libs/libvterm
dev-lua/lpeg[luajit=]
dev-lua/mpack[luajit=]
- jemalloc? ( dev-libs/jemalloc )
-"
-DEPEND="${CDEPEND}
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
virtual/libiconv
virtual/libintl"
-RDEPEND="${CDEPEND}
+
+RDEPEND="
+ ${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"