summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-doc
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/halibut/halibut-1.1.ebuild9
-rw-r--r--app-doc/halibut/halibut-1.2.ebuild4
2 files changed, 6 insertions, 7 deletions
diff --git a/app-doc/halibut/halibut-1.1.ebuild b/app-doc/halibut/halibut-1.1.ebuild
index 9b4f6966032f..e5cc35e2aa70 100644
--- a/app-doc/halibut/halibut-1.1.ebuild
+++ b/app-doc/halibut/halibut-1.1.ebuild
@@ -20,15 +20,14 @@ src_compile() {
LFLAGS="${LDFLAGS}" \
emake -j1 \
BUILDDIR="${S}/build" \
- VERSION="${PV}" \
- || die "make failed"
+ VERSION="${PV}"
- emake -C doc || die "make in doc failed"
+ emake -C doc
}
src_install() {
- dobin build/halibut || die
- doman doc/halibut.1 || die
+ dobin build/halibut
+ doman doc/halibut.1
dodoc doc/halibut.txt
dohtml doc/*.html
}
diff --git a/app-doc/halibut/halibut-1.2.ebuild b/app-doc/halibut/halibut-1.2.ebuild
index 81ec54f31f0c..13c64206e3f6 100644
--- a/app-doc/halibut/halibut-1.2.ebuild
+++ b/app-doc/halibut/halibut-1.2.ebuild
@@ -21,8 +21,8 @@ src_compile() {
LFLAGS="${LDFLAGS}" \
BUILDDIR="${S}/build" \
VERSION="${PV}" \
- emake || die "make failed"
- emake -C doc || die "make in doc failed"
+ emake
+ emake -C doc
}
DOCS=( doc/halibut.txt )