summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-07 08:56:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-07 08:56:35 +0200
commit638b582cfc90c4eea390c41c3814377127f44950 (patch)
tree5d2e2004e3a9dca2d1f0085c0ec65b1a3482a126 /app-doc/python-docs/python-docs-3.10.15.ebuild
parentapp-doc/python-docs: Bump to 3.11.10 (diff)
downloadgentoo-638b582cfc90c4eea390c41c3814377127f44950.tar.gz
gentoo-638b582cfc90c4eea390c41c3814377127f44950.tar.bz2
gentoo-638b582cfc90c4eea390c41c3814377127f44950.zip
app-doc/python-docs: Bump to 3.10.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/python-docs/python-docs-3.10.15.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-3.10.15.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-3.10.15.ebuild b/app-doc/python-docs/python-docs-3.10.15.ebuild
new file mode 100644
index 000000000000..8483ad559ab4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}