summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-11 03:16:13 +0000
committerSam James <sam@gentoo.org>2021-12-11 03:16:22 +0000
commit8800fe256e29073620ad0f0673bf05167456654b (patch)
treefd7638aa810fddc54085197dab1f9c89695da21e /app-doc/linuxfromscratch/linuxfromscratch-11.0.ebuild
parentdev-ml/dune-build-info: new package; add version 2.9.1 (diff)
downloadgentoo-8800fe256e29073620ad0f0673bf05167456654b.tar.gz
gentoo-8800fe256e29073620ad0f0673bf05167456654b.tar.bz2
gentoo-8800fe256e29073620ad0f0673bf05167456654b.zip
app-doc/linuxfromscratch: add 11.0
Closes: https://bugs.gentoo.org/666420 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc/linuxfromscratch/linuxfromscratch-11.0.ebuild')
-rw-r--r--app-doc/linuxfromscratch/linuxfromscratch-11.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-doc/linuxfromscratch/linuxfromscratch-11.0.ebuild b/app-doc/linuxfromscratch/linuxfromscratch-11.0.ebuild
new file mode 100644
index 000000000000..71405c6d4d50
--- /dev/null
+++ b/app-doc/linuxfromscratch/linuxfromscratch-11.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_SRC="https://www.linuxfromscratch.org/lfs/downloads/${PV}"
+BOOTSCRIPT_PV="20210608"
+
+DESCRIPTION="LFS documents building a Linux system entirely from source"
+HOMEPAGE="http://www.linuxfromscratch.org/lfs"
+SRC_URI="${MY_SRC}/LFS-BOOK-${PV}.tar.bz2
+ ${MY_SRC}/lfs-bootscripts-${BOOTSCRIPT_PV}.tar.xz
+ ${MY_SRC}-systemd/LFS-BOOK-${PV}.tar.bz2 -> LFS-BOOK-${PV}-systemd.tar.bz2
+ htmlsingle? (
+ ${MY_SRC}/LFS-BOOK-${PV}-NOCHUNKS.html
+ ${MY_SRC}-systemd/LFS-BOOK-${PV}-NOCHUNKS.html
+ )
+ pdf? (
+ ${MY_SRC}/LFS-BOOK-${PV}.pdf
+ ${MY_SRC}-systemd/LFS-BOOK-${PV}-systemd.pdf
+ )"
+S="${WORKDIR}"
+
+LICENSE="CC-BY-NC-SA-2.5 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="htmlsingle pdf"
+
+src_unpack() {
+ unpack lfs-bootscripts-${BOOTSCRIPT_PV}.tar.xz
+ unpack LFS-BOOK-${PV}.tar.bz2
+
+ (
+ mkdir -p "${S}"/systemd || die
+ cd "${S}"/systemd || die
+ unpack LFS-BOOK-${PV}-systemd.tar.bz2
+ )
+
+ if use htmlsingle; then
+ cp "${DISTDIR}"/LFS-BOOK-${PV}{,-systemd}-NOCHUNKS.html "${S}" || die
+ fi
+
+ if use pdf; then
+ cp "${DISTDIR}"/LFS-BOOK-${PV}{,-systemd}.pdf "${S}" || die
+ fi
+}
+
+src_install() {
+ dodoc -r *
+ docompress -x /usr/share/doc/${PF}
+}