summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-07-25 11:16:27 +0200
committerFabian Groffen <grobian@gentoo.org>2024-07-25 11:17:45 +0200
commit8bda632b707207572f7e2b2ba28dac4dfa8dec38 (patch)
tree96faf36a7c07b1c92fe01caf8c8d1ef11ce74f8b /app-crypt
parentdev-java/tomcat-native: add 2.0.8 (diff)
downloadgentoo-8bda632b707207572f7e2b2ba28dac4dfa8dec38.tar.gz
gentoo-8bda632b707207572f7e2b2ba28dac4dfa8dec38.tar.bz2
gentoo-8bda632b707207572f7e2b2ba28dac4dfa8dec38.zip
app-crypt/libb2-0.98.1-r3: fix compilation on Solaris
This may have broken after an OpenIndiana update, or compiler update. Make sure memset_s can be found both during configure and compilation. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1-r3.ebuild b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
index f810cc600ecf..0137d18d8f28 100644
--- a/app-crypt/libb2/libb2-0.98.1-r3.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools multilib-minimal toolchain-funcs
+inherit autotools multilib-minimal toolchain-funcs flag-o-matic
DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -40,6 +40,8 @@ src_prepare() {
sed -i -e 's/ == / = /' configure.ac || die
# https://github.com/BLAKE2/libb2/pull/28
echo 'libb2_la_LDFLAGS = -no-undefined' >> src/Makefile.am || die
+ # make memset_s available
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -D__STDC_WANT_LIB_EXT1__=1
eautoreconf # upstream doesn't make releases
}