summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-24 00:35:51 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-24 00:37:07 +0100
commit7ad518820dd1b115f4776ef5ba4fe5c620377c6b (patch)
tree75adf9c2931266c9d6a87f4ac89228fa62e2daed /app-crypt
parentdev-python/keyring: enable py3.12 (diff)
downloadgentoo-7ad518820dd1b115f4776ef5ba4fe5c620377c6b.tar.gz
gentoo-7ad518820dd1b115f4776ef5ba4fe5c620377c6b.tar.bz2
gentoo-7ad518820dd1b115f4776ef5ba4fe5c620377c6b.zip
app-crypt/yubikey-manager: add 5.2.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest2
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index aa5231e444e9..afc799a89612 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,2 +1,4 @@
DIST yubikey_manager-5.1.1.tar.gz 167947 BLAKE2B 4f0b7a3ba3f083112c0a43c9b9304e7f79526d7a31991959dc8a30e86f41b0ec616c9ed7790a551d998dc481bd18a89e87598c2534b8390a831572a77a36c32d SHA512 9da9588bb311594d2b4d2d8b234b64f333dfc7dc57145e250965bd9d058cfda43a9c9a32991081ac069819812bebaf0c10a24afab4ac444891ab21d2cff81c06
DIST yubikey_manager-5.1.1.tar.gz.sig 310 BLAKE2B 4f636b5eab0602ec203c8d3d5b6d1de85c7341559b09fc131a994c75b15cb141706ccc65a8efb39e33d5a3704496e85c08a67d105d45f5264644b993c2585f20 SHA512 e964e39a995de7bd24a3e417d5e98cf68cdcd6412b7c95b552545468bbb434105fad97bbf82d758c9320bf9917d32312e6e286e9259d004899af2cde540cc731
+DIST yubikey_manager-5.2.0.tar.gz 184873 BLAKE2B 09041c23e23ff01cad2d126face63006d1648dfe8d2e7a47b7113deed990143c83a36b6c60458dc9cbf55a71ddf286b8259c97ee982044dbc554231655fb82e2 SHA512 988c25f378e0ce5b53ba5a47aac5fd5a136653f1592af5e9c7440eef7336903cf459a567b4be02119262dba70c3058f5d9f26049dc21c1d934dcf8897eedc03d
+DIST yubikey_manager-5.2.0.tar.gz.sig 309 BLAKE2B bb1a012832c99aaa94404717560e72fb93352b82dd3c0091cb492cde65706c39b9e2411e38a36150d77e72f6397d98cef643d0b392c1751e9c109de3468c9a39 SHA512 926a7a7c40d38bcc0a48e3b44f3eb673c16f7bed73701f5cb6f9ac4418c9f2a242b8d2af9459093ec10e8c188410412a8ba8c05a0fd4774a738629a4b0f874d4
diff --git a/app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild
new file mode 100644
index 000000000000..96849c7bc968
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1 verify-sig
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# According to https://github.com/Yubico/yubikey-manager/issues/518 the release
+# tarballs on Yubico Web site and on GitHub should be identical, and at least
+# for recent releases the latter are signed as well. Only the automatically
+# generated "Source code (tar.gz)" tarballs should not be used.
+# Still, prefer the former if available.
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz
+ verify-sig? ( https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz.sig )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/yubico.com.asc"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/cryptography-44[${PYTHON_USEDEP}]
+ dev-python/fido2:0/1.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-23.4[${PYTHON_USEDEP}]
+ >=dev-python/pyscard-2.0[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? ( dev-python/makefun[${PYTHON_USEDEP}] )
+ verify-sig? ( >=sec-keys/openpgp-keys-yubico-20220824 )"
+
+S="${WORKDIR}"/${MY_P}
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}