summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 21:03:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 21:26:14 +0200
commit4b369e0d3fcdb8b79cd9adcda41a26786f40ca6d (patch)
tree59c53867d45f186e86692fae1e013f5158621e58 /app-crypt
parentdev-python/elastic-transport: Enable py3.13 (diff)
downloadgentoo-4b369e0d3fcdb8b79cd9adcda41a26786f40ca6d.tar.gz
gentoo-4b369e0d3fcdb8b79cd9adcda41a26786f40ca6d.tar.bz2
gentoo-4b369e0d3fcdb8b79cd9adcda41a26786f40ca6d.zip
app-crypt/acme: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/acme-2.10.0.ebuild12
-rw-r--r--app-crypt/acme/acme-9999.ebuild12
2 files changed, 16 insertions, 8 deletions
diff --git a/app-crypt/acme/acme-2.10.0.ebuild b/app-crypt/acme/acme-2.10.0.ebuild
index c4eb5dcd71c8..8c850f30473b 100644
--- a/app-crypt/acme/acme-2.10.0.ebuild
+++ b/app-crypt/acme/acme-2.10.0.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -37,8 +37,6 @@ SLOT="0"
BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"
@@ -55,5 +53,11 @@ RDEPEND="
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 1bdc2aa52244..6df08330928b 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -37,8 +37,6 @@ SLOT="0"
BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"
@@ -55,5 +53,11 @@ RDEPEND="
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}