summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 17:30:20 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 17:33:47 +0100
commit48bb5661d6778a67775f0c5b12d054b72c101c5b (patch)
tree045b68de9364b2e8dbdeb42334766e409fec3715 /app-crypt
parentapp-crypt/minisign: Remove the live ebuild (diff)
downloadgentoo-48bb5661d6778a67775f0c5b12d054b72c101c5b.tar.gz
gentoo-48bb5661d6778a67775f0c5b12d054b72c101c5b.tar.bz2
gentoo-48bb5661d6778a67775f0c5b12d054b72c101c5b.zip
app-crypt/minisign: Clean the ebuild up
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/minisign/minisign-0.11-r1.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/app-crypt/minisign/minisign-0.11-r1.ebuild b/app-crypt/minisign/minisign-0.11-r1.ebuild
index 4719129eccdc..adf0b7060096 100644
--- a/app-crypt/minisign/minisign-0.11-r1.ebuild
+++ b/app-crypt/minisign/minisign-0.11-r1.ebuild
@@ -6,24 +6,29 @@ EAPI=8
inherit cmake
DESCRIPTION="Dead simple tool to sign files and verify signatures"
-HOMEPAGE="https://github.com/jedisct1/minisign"
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
-else
- SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
+HOMEPAGE="https://github.com/jedisct1/minisign/"
+SRC_URI="
+ https://github.com/jedisct1/minisign/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="ISC"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-BDEPEND="virtual/pkgconfig"
-DEPEND="dev-libs/libsodium:=[-minimal(-)]"
-RDEPEND="${DEPEND}"
+DEPEND="
+ dev-libs/libsodium:=[-minimal(-)]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
src_configure() {
- local mycmakeargs=( -DCMAKE_STRIP=OFF )
+ local mycmakeargs=(
+ -DCMAKE_STRIP=OFF
+ )
cmake_src_configure
}