summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-08-19 14:57:25 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 17:11:17 +0300
commita644a58975e4039a7842b8f2bc34ef305218fe05 (patch)
tree84463988c5e485f18689068d472137d02d7dc017 /app-crypt/tpm2-abrmd
parentdev-db/sqlcl-bin: removed old (diff)
downloadgentoo-a644a58975e4039a7842b8f2bc34ef305218fe05.tar.gz
gentoo-a644a58975e4039a7842b8f2bc34ef305218fe05.tar.bz2
gentoo-a644a58975e4039a7842b8f2bc34ef305218fe05.zip
app-crypt/tpm2-abrmd: Bump to 2.3.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-abrmd')
-rw-r--r--app-crypt/tpm2-abrmd/Manifest1
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-2.3.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/tpm2-abrmd/Manifest b/app-crypt/tpm2-abrmd/Manifest
index de55f4dfed4d..8c93ee844f61 100644
--- a/app-crypt/tpm2-abrmd/Manifest
+++ b/app-crypt/tpm2-abrmd/Manifest
@@ -1,2 +1,3 @@
DIST tpm2-abrmd-2.1.1.tar.gz 561352 BLAKE2B 4106811b238fee7b503bf0afb4ed857371bab023d8e449d5864eebb2386779e2bc8fb0f2bf8e334ebd8d7abe5c569f2b2cc2ea60b07672b1d3294092e63c2a5a SHA512 d685812c26a097190ced5a9e8ceb1544eb9e3858606123644d5496031706af91e5ba9fb54eb371bcb4eed4d236617f7a21a49a792196db9c5ebf277582ac7124
DIST tpm2-abrmd-2.3.1.tar.gz 566988 BLAKE2B 281c1288baaa07b93939219143f4ecc2420b353d04d751746b6e43c93e092d0facb3d0ddbc20129328666d69954dd16ea7e709fea99690af80b2c83e1ac855e4 SHA512 144ab2b147cd18f892f3c05181efdbed2ac422fe8507eb42871ffe571340b6395431743a4f1995a7ce7a914fd5e7afd2b17328062c893a0403708c2c4d92e0cb
+DIST tpm2-abrmd-2.3.3.tar.gz 573449 BLAKE2B c3bc0311a73a0c69060a4d19517c3b5d09077ee8efdcd6e7d605675111cb5ac568d1e43bf9c329d4fad21fd44fb50b20e502205360461533c68866d329c320db SHA512 2191c7e466271cb85fcb20fcd91c78df80f53030fb055d0b4670db33708939b60a9124955356f27662975abdcb9c8d144df884003986ffdbd801ca4e47edc21a
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.3.3.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.3.3.ebuild
new file mode 100644
index 000000000000..53562b771fdc
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="TPM2 Access Broker & Resource Manager"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-abrmd"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ sys-apps/dbus:=
+ dev-libs/glib:=
+ app-crypt/tpm2-tss:="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
+ dev-util/gdbus-codegen"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d" \
+ --with-systemdpresetdir="$(systemd_get_systemunitdir)/../system-preset" \
+ --with-systemdpresetdisable \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}