summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-01-31 12:48:34 +0000
committerMarek Szuba <marecki@gentoo.org>2024-01-31 12:55:22 +0000
commit68c9b8f93ff895caa7bf5aaee085e66ffb7862a4 (patch)
tree38d64f04ff73745b70d6d2bcb54a9c23f4052c0f /app-crypt/chntpw
parentapp-emulation/vagrant: unkeyword 2.4.0 for ~arm64 (diff)
downloadgentoo-68c9b8f93ff895caa7bf5aaee085e66ffb7862a4.tar.gz
gentoo-68c9b8f93ff895caa7bf5aaee085e66ffb7862a4.tar.bz2
gentoo-68c9b8f93ff895caa7bf5aaee085e66ffb7862a4.zip
app-crypt/chntpw: force -std=gnu90
Just a workaround for build errors for now. In the long run, I think I'd better look at whether how useful exactly (if at all) chntpw is against modern Windows versions, warrants all the changes required to make the code C99-compliant. Nb. It's gnu90 rather than c90 because of the use of // for comments. Closes: https://bugs.gentoo.org/919172 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/chntpw-140201-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-crypt/chntpw/chntpw-140201-r1.ebuild b/app-crypt/chntpw/chntpw-140201-r1.ebuild
index 2aeae846a75b..8594fba742f8 100644
--- a/app-crypt/chntpw/chntpw-140201-r1.ebuild
+++ b/app-crypt/chntpw/chntpw-140201-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Offline Windows NT Password & Registry Editor"
HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
@@ -34,6 +34,9 @@ src_prepare() {
default
sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+ # MANY changes would be required for this code to be c99-compliant
+ append-flags -std=gnu90
+
if ! use static ; then
sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
fi