summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-09-29 15:45:44 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-09-29 16:42:21 +0200
commit84d4085a51dc05af3b2fa6928fd99b2e3ea76c7a (patch)
treef0978120dfef0919df5e8febd1d71862167bd5ca /app-crypt/acme-sh
parentapp-crypt/acme-sh: add 3.0.9 (diff)
downloadgentoo-84d4085a51dc05af3b2fa6928fd99b2e3ea76c7a.tar.gz
gentoo-84d4085a51dc05af3b2fa6928fd99b2e3ea76c7a.tar.bz2
gentoo-84d4085a51dc05af3b2fa6928fd99b2e3ea76c7a.zip
app-crypt/acme-sh: drop 3.0.7, 3.0.8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest2
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.7.ebuild54
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.8.ebuild54
3 files changed, 0 insertions, 110 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 799722924027..7e9c651e8b29 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1,3 +1 @@
-DIST acme.sh-3.0.7.tar.gz 284269 BLAKE2B 2e3d81446772049660d3a7b8005b82a890238d33ef16211b304ecd9b996063de9e788095ff958422f90d2e20615f84943d6085959ac2f27d6ad51a8eeffb2800 SHA512 83d080b461662bf2c5cfa9cb51aaf41d7f873f54908e2e5f94d7e3fe8e3f6953d73aafb66adc97455aa958f37c72ef77ba475c7d7cbb3ca3c5bbffb4937c4bae
-DIST acme.sh-3.0.8.tar.gz 296583 BLAKE2B becc2402edb9cfb867662b91dd0925c151b21cc56d9c956513678ede22cab1ddcb0cdf424131d301f349a10245a5566fcfcf87f16b927b5c7fb9211e9f070de5 SHA512 e18e75557a4b10a71a726bbef6383c7bc9276b7dcdcc80756da3136b2d9f819e787ef477fec326d05d96dbc90c114fb2a418889aaac996717a6c456cd131d30b
DIST acme.sh-3.0.9.tar.gz 298025 BLAKE2B 166e311c63801cb6b4c8aade7afff63cba48ad74932c64b16a0ceb330176465548d9d99da5216b3c00146c59d37b48b24fb4c4bb1220bc5b7ea652d9000fddb1 SHA512 5f7431051de74ec1feca90d743233ddcec2a955e789e5237730498930c910d2a728c3f5e447a09f470a007ed9a4c90de329be58867d15a0fd13f6f18dca49bd0
diff --git a/app-crypt/acme-sh/acme-sh-3.0.7.ebuild b/app-crypt/acme-sh/acme-sh-3.0.7.ebuild
deleted file mode 100644
index 321de0c3a864..000000000000
--- a/app-crypt/acme-sh/acme-sh-3.0.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="${PN/-/.}"
-MY_P="${MY_PN}-${PV}"
-
-inherit optfeature
-
-DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
-HOMEPAGE="https://github.com/acmesh-official/acme.sh"
-SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-IUSE="selinux"
-
-RDEPEND="
- dev-libs/openssl:0
- net-misc/curl
- net-misc/socat
- selinux? ( sec-policy/selinux-certbot )
-"
-
-src_install() {
- newdoc deploy/README.md README-deploy.md
- newdoc dnsapi/README.md README-dnsapi.md
- rm {deploy,dnsapi}/README.md || die
- einstalldocs
-
- exeinto /usr/share/acme.sh
- doexe acme.sh
-
- insinto /usr/share/acme.sh
- doins -r deploy dnsapi notify
-
- keepdir /etc/acme-sh
- doenvd "${FILESDIR}"/99acme-sh
-
- insinto /etc/bash/bashrc.d
- doins "${FILESDIR}"/acme.sh
-
- dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
-}
-
-pkg_postinst() {
- optfeature_header "For webserver mode, install a supported web server:"
- optfeature "using apache2 webserver mode" www-servers/apache
- optfeature "using nginx webserver mode" www-servers/nginx
-}
diff --git a/app-crypt/acme-sh/acme-sh-3.0.8.ebuild b/app-crypt/acme-sh/acme-sh-3.0.8.ebuild
deleted file mode 100644
index 541a699d4997..000000000000
--- a/app-crypt/acme-sh/acme-sh-3.0.8.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="${PN/-/.}"
-MY_P="${MY_PN}-${PV}"
-
-inherit optfeature
-
-DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
-HOMEPAGE="https://github.com/acmesh-official/acme.sh"
-SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-IUSE="selinux"
-
-RDEPEND="
- dev-libs/openssl:0
- net-misc/curl
- net-misc/socat
- selinux? ( sec-policy/selinux-certbot )
-"
-
-src_install() {
- newdoc deploy/README.md README-deploy.md
- newdoc dnsapi/README.md README-dnsapi.md
- rm {deploy,dnsapi}/README.md || die
- einstalldocs
-
- exeinto /usr/share/acme.sh
- doexe acme.sh
-
- insinto /usr/share/acme.sh
- doins -r deploy dnsapi notify
-
- keepdir /etc/acme-sh
- doenvd "${FILESDIR}"/99acme-sh
-
- insinto /etc/bash/bashrc.d
- doins "${FILESDIR}"/acme.sh
-
- dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
-}
-
-pkg_postinst() {
- optfeature_header "For webserver mode, install a supported web server:"
- optfeature "using apache2 webserver mode" www-servers/apache
- optfeature "using nginx webserver mode" www-servers/nginx
-}