summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-03-07 00:06:17 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-03-07 00:12:43 -0600
commitf69028fe0c373510339ace6e44ed9a9655945156 (patch)
tree00ee793cccbabbe8092da11360d8c2a5ca88b019 /app-containers/kompose/kompose-1.26.1.ebuild
parentdev-lang/python: fix WhitespaceFound (diff)
downloadgentoo-f69028fe0c373510339ace6e44ed9a9655945156.tar.gz
gentoo-f69028fe0c373510339ace6e44ed9a9655945156.tar.bz2
gentoo-f69028fe0c373510339ace6e44ed9a9655945156.zip
app-containers/kompose: 1.26.1 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/kompose/kompose-1.26.1.ebuild')
-rw-r--r--app-containers/kompose/kompose-1.26.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/kompose/kompose-1.26.1.ebuild b/app-containers/kompose/kompose-1.26.1.ebuild
new file mode 100644
index 000000000000..1db26ca08272
--- /dev/null
+++ b/app-containers/kompose/kompose-1.26.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+GIT_COMMIT=a9d05d50
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="https://github.com/kubernetes/kompose/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ sed -i -e 's/-w -s//' Makefile || die
+}
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake \
+ GITCOMMIT=${GIT_COMMIT} \
+ bin
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc -r docs examples {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
+}