summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-07 12:47:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-07 12:47:27 -0500
commit6059182799bb8c1079337ff07e95782ab91a2e58 (patch)
treeb3696da0e1d9ca8073ef3eb66ea1e7ba67451ce3 /app-containers/docker-cli
parentapp-containers/docker: add 23.0.3 (diff)
downloadgentoo-6059182799bb8c1079337ff07e95782ab91a2e58.tar.gz
gentoo-6059182799bb8c1079337ff07e95782ab91a2e58.tar.bz2
gentoo-6059182799bb8c1079337ff07e95782ab91a2e58.zip
app-containers/docker-cli: add 23.0.3
Closes: https://bugs.gentoo.org/903931 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/docker-cli')
-rw-r--r--app-containers/docker-cli/Manifest2
-rw-r--r--app-containers/docker-cli/docker-cli-23.0.3.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/app-containers/docker-cli/Manifest b/app-containers/docker-cli/Manifest
index 57177d40b1f8..28441da4838b 100644
--- a/app-containers/docker-cli/Manifest
+++ b/app-containers/docker-cli/Manifest
@@ -1,3 +1,5 @@
DIST docker-cli-20.10.22.tar.gz 7590020 BLAKE2B ab003a9af2b441a9bad9c27345dea2e82087cfc8a8ac865adeb2e47e91be4bd9b27f499ae95b0ddcddb66d27c3498938682dcd10d5e3bef41fc18ce1f034a476 SHA512 550346904d172725f48c4de0e34fa95123c7022b14980d30cd01df0c9e154ac817f19e24b61538f8cbc23db090de56977c8b885b96f99583e8a5f773691280a6
DIST docker-cli-23.0.1-man.tar.xz 81956 BLAKE2B 4660d760fc405f9c3fdc38d7324c34d6a5ab1c567f792d400b91b57e2f3c2257b72cd1b02cab2fde8016ac37f6630e6c5c60da0d9064250f341baf3a5e28419a SHA512 88b926f661f3d291dbd71c0ba6f930c13e81760b354f8abccf802abd8175f312a7b3487ed3d767ae02e3c3d4172d02b6bf55b21b3921c9850a05de5efc204b1f
DIST docker-cli-23.0.1.tar.gz 6215114 BLAKE2B 4449de9fdc64f45daf6dbbe762bf6e2320aa32bed1aba90a3c1c81df343f3c3a667e62e950896f5d2b12e33d758507b4cec7d6ed3b06c3815ad528be2c47510a SHA512 77d30945160dc4d9c50354c57d2efed49b99c872c8782f6ad121e6dc1489899d8967ba95cca36499c1b59bc5ef71f4a6b516c635b0cf41b50722bb71597aa496
+DIST docker-cli-23.0.3-man.tar.xz 81976 BLAKE2B e7390b429d0db2445035da506bb796364f97e6560e766a28d1245e6a76c84314c38af1f3a946d2eb1785132d26805e0d3a76c374559e70989b64e8ce917f8423 SHA512 842d7187ad8a3933d815057ec535c13466c56bd051c7133e6e0a9c85f5140e4ef61b66771ee6788c8fb50d10652a86b663f29fe4ec3190773f70fd45f36fbcd4
+DIST docker-cli-23.0.3.tar.gz 6215298 BLAKE2B 817ca474d61839c8b5929db9bfa964b936285622859ab30f45be2f382238a5e49987fdbcdc896eaa7109f114166cf0e1dbc4f001cefe293a6c286b50e2737258 SHA512 873783a0fe9ecab3b8f251c842ba69070e0dffbb4a758c16165441b2f483d55d15b98fd7da0707e483995ac2d1fbb9a0f13f570b78486382b26d6ca6c5e612a9
diff --git a/app-containers/docker-cli/docker-cli-23.0.3.ebuild b/app-containers/docker-cli/docker-cli-23.0.3.ebuild
new file mode 100644
index 000000000000..3fd0fb8307b1
--- /dev/null
+++ b/app-containers/docker-cli/docker-cli-23.0.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GIT_COMMIT=3e7cbfdee1
+EGO_PN="github.com/docker/cli"
+MY_PV=${PV/_/-}
+inherit bash-completion-r1 golang-vcs-snapshot
+
+DESCRIPTION="the command line binary for docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-man.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="hardened selinux"
+
+RDEPEND="!<app-containers/docker-20.10.1
+ selinux? ( sec-policy/selinux-docker )"
+BDEPEND="
+ >=dev-lang/go-1.16.6"
+
+RESTRICT="installsources strip test"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_unpack() {
+ golang-vcs-snapshot_src_unpack
+ set -- ${A}
+ unpack ${2}
+}
+
+src_prepare() {
+ default
+ sed -i 's@dockerd\?\.exe@@g' contrib/completion/bash/docker || die
+}
+
+src_compile() {
+ export DISABLE_WARN_OUTSIDE_CONTAINER=1
+ export GOPATH="${WORKDIR}/${P}"
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
+ emake \
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
+ VERSION="${PV}" \
+ GITCOMMIT="${GIT_COMMIT}" \
+ dynbinary
+}
+
+src_install() {
+ dobin build/docker
+ doman "${WORKDIR}"/man/man?/*
+ dobashcomp contrib/completion/bash/*
+ bashcomp_alias docker dockerd
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completion/fish/docker.fish
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/_*
+}
+
+pkg_postinst() {
+ has_version "app-containers/docker-buildx" && return
+ ewarn "the 'docker build' command is deprecated and will be removed in a"
+ ewarn "future release. If you need this functionality, install"
+ ewarn "app-containers/docker-buildx."
+}