summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2024-02-19 07:16:15 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-28 10:11:20 +0100
commit97223cb92ff7da3a5d3d7fc836a5536883c0e083 (patch)
tree618f1c238cb3f720e475f7ea427d78d2e46e7e7d /app-containers/crun
parentapp-containers/crun: bump to 1.14.3 (diff)
downloadgentoo-97223cb92ff7da3a5d3d7fc836a5536883c0e083.tar.gz
gentoo-97223cb92ff7da3a5d3d7fc836a5536883c0e083.tar.bz2
gentoo-97223cb92ff7da3a5d3d7fc836a5536883c0e083.zip
app-containers/crun: drop 1.8.1
Signed-off-by: Robert Günzler <r@gnzler.io> Closes: https://github.com/gentoo/gentoo/pull/35420 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-containers/crun')
-rw-r--r--app-containers/crun/Manifest1
-rw-r--r--app-containers/crun/crun-1.8.1.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/app-containers/crun/Manifest b/app-containers/crun/Manifest
index 217c3acfde92..3e403e47f1cf 100644
--- a/app-containers/crun/Manifest
+++ b/app-containers/crun/Manifest
@@ -1,4 +1,3 @@
DIST crun-1.11.2.tar.xz 738176 BLAKE2B ef13475089c87599159ce00dd26fbb19c7f2bb9564352c1f8040925e521bb924cf28a8d1f37cc95ce7d1b2797b8654740e9ad08352e357c8c9e2d176466101e0 SHA512 ae35ffb9bd1c7acebfd7f6236fa6a7ad524593d8f2cea1203f0e89023e9791d2d5bbc5c5cfc32ee5f18ad80662a1659076ab5f4d5ff74c6026842f2dd12be977
-DIST crun-1.8.1.tar.xz 692152 BLAKE2B b5dce1a454641221c591f50ac8519d4e9e9d892ea56232fa3fc9916934c19eba5853019238b1837cd5fb61f0dec5e0e6a11c02f628bece3b69c9c4f5750addae SHA512 6230b378f4746aff1d53f3ed797229b2056ece76e8e5b22d6f5f7b42e6042c6aff5294298f3cfd1293b4a87371dfa58cc69e57455e20948abd7269059ad39042
DIST crun-1.14.3.tar.xz 750456 BLAKE2B 5a63b5da2f85ff1a83d4589be224c5b7a1123b6d7714b90a63c1907b78d42392aff25ffe5d9a4127173ac47026d57e9c93a39f5ba4b07de7f9f3722c14e6d203 SHA512 d6645c519ff00dda5def6d58240600d15e76969489918d51c0def2fee7dbad6374f83e5afc14a998d176aa2944765df5cd84c3031b265a1931ab23f2fc965fc1
DIST crun-1.8.4.tar.xz 729552 BLAKE2B 8169518a0ddd8deb3820f7030d03dec6941d5d34fb73a036b82f15b0d8f2f702e117de00b829a16cb9976e118f5a5ca732b1cd572708f664cfeafc564f883824 SHA512 2ed80db2e7ddd1438bbe33e99ec2cdbcc55c4869504f719ff9302e834929752af09a59cd905accb37ee5f6cae3b9b16fd4f4c3fdab31db5fc38b007c1505bfa0
diff --git a/app-containers/crun/crun-1.8.1.ebuild b/app-containers/crun/crun-1.8.1.ebuild
deleted file mode 100644
index c0e0200e403c..000000000000
--- a/app-containers/crun/crun-1.8.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-# Can drop autotools/eautoreconf after next release & glibc patch gone
-inherit autotools python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv"
-IUSE="+bpf +caps criu +seccomp selinux systemd static-libs"
-
-DEPEND="
- dev-libs/libgcrypt:=
- dev-libs/yajl:=
- sys-kernel/linux-headers
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}
- selinux? ( sec-policy/selinux-container )"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake git-version.h
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-
- einfo "Cleaning up .la files"
- find "${ED}" -name '*.la' -delete || die
-}