summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-08-28 08:22:58 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-08-28 08:23:16 -0500
commitaa282db2c38fc0fc6ded671b25d3be01aa01756a (patch)
treedef604bc7f717c7f1c82bd4c12d11995add6deef /app-containers/cosign
parentdev-python/ensurepip-setuptools: Bump to 74.0.0 (diff)
downloadgentoo-aa282db2c38fc0fc6ded671b25d3be01aa01756a.tar.gz
gentoo-aa282db2c38fc0fc6ded671b25d3be01aa01756a.tar.bz2
gentoo-aa282db2c38fc0fc6ded671b25d3be01aa01756a.zip
app-containers/cosign: add 2.4.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/cosign')
-rw-r--r--app-containers/cosign/Manifest2
-rw-r--r--app-containers/cosign/cosign-2.4.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/cosign/Manifest b/app-containers/cosign/Manifest
index df934f1cd5af..635562655183 100644
--- a/app-containers/cosign/Manifest
+++ b/app-containers/cosign/Manifest
@@ -10,3 +10,5 @@ DIST cosign-2.2.3-deps.tar.xz 429760040 BLAKE2B 47ee9a4f6305a670e1818ce74a9da351
DIST cosign-2.2.3.tar.gz 845096 BLAKE2B 2017cc1716899640cbfc10ce093280a1ee4789eb1e8a8077978ebe4efe38075efa73ccb1abecb41eaa64dc16e652dbb709be7f195a6542284d86b2d9fb5128f3 SHA512 fc488c80dab3d05e0eca714c6107fada01dfddc2b68747676665d20a3f229224bbe36bfc60625c581c2e80dd10ad1421e142cf7ef6e24eba0894a708f2d10f06
DIST cosign-2.2.4-deps.tar.xz 153098164 BLAKE2B 6e900386c307fc5bc19057ab62d87eb6ff597916d3cabf14372ce8cd4b39c0fd11ec787fcb96d3db297c7907584617307ab3a87b2e797de56ef6dee4cff3f50b SHA512 d0873fd15819c9c580a8f70a01859ac8e166ba79f9702fe757d95b482ee92914c66b13b9abe3093f79b9657612d9c7da8ce662aca7bc680ff533c7fcb1848e30
DIST cosign-2.2.4.tar.gz 840586 BLAKE2B 22522fc70ff6b01957af2e294b7fdad740d55cc9710f9023246855dd9383be0688934f27e5b32cde3383cdfe3c02cd2de5547a515a14c1442ac85afc9e566b8f SHA512 3a2e2e7ea3964428bc7c4adb9475fbb730cbe2b7dfa7a5eb5cf350d88a4f3a9aef64f00574c7f38bf0074cb3e386cd26e6cfe4558ce5989ea557b654aa82ef71
+DIST cosign-2.4.0-deps.tar.xz 153232112 BLAKE2B 9aa2da10bb063a554c4722ed3523ab1ec332209eec3d1adffa53d22ddec4296b834a2c9194323684ef27d738439818ba9e6e8539ca10e17eb40a835178eaf7fb SHA512 ff3a16420d2e0291bb67f856cd21ad519fcdbd08489cfd9dfe29aa816d077f6fc32ec1d314291f4811ae717270448b92c000e1a0d115a9b5f1346f17567e78a5
+DIST cosign-2.4.0.tar.gz 864498 BLAKE2B 7154e8b1b171e2491f68a000925b9ad2e59dd8eae8fa5431e482dfdb1b9e04dd42b59c988d765eae615dedc95b35d34d82b3adb9ae7a0bf4bd0a5fefde7a39c5 SHA512 35a57a0cd627d470c957da972e9acbc415a4b7ab0d9ead7e3d3499ecac5a167d93026f886d1c686882a97daac75944d326b06b292cb614ce8e727c81be04fdcb
diff --git a/app-containers/cosign/cosign-2.4.0.ebuild b/app-containers/cosign/cosign-2.4.0.ebuild
new file mode 100644
index 000000000000..de622f965ee3
--- /dev/null
+++ b/app-containers/cosign/cosign-2.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_HASH=b5e7dc123a272080f4af4554054797296271e902
+SOURCE_DATE_EPOCH=1722980393
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean \
+ SOURCE_DATE_EPOCH=${SOURCE_DATE_EPOCH}
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+dodoc CHANGELOG.md
+}