summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-07-24 16:26:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-07-24 16:26:27 -0500
commit71dac8ebf3c78478b90689b30c98c5b43c36899a (patch)
tree2c89c308c13e82cb8a6c771d10f86c2edfd44a47 /app-containers/containerd
parentsys-kernel/gentoo-sources: drop 5.4.249 (diff)
downloadgentoo-71dac8ebf3c78478b90689b30c98c5b43c36899a.tar.gz
gentoo-71dac8ebf3c78478b90689b30c98c5b43c36899a.tar.bz2
gentoo-71dac8ebf3c78478b90689b30c98c5b43c36899a.zip
app-containers/containerd: drop 1.6.20, 1.7.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/containerd')
-rw-r--r--app-containers/containerd/Manifest1
-rw-r--r--app-containers/containerd/containerd-1.6.20.ebuild85
-rw-r--r--app-containers/containerd/containerd-1.7.1.ebuild85
3 files changed, 0 insertions, 171 deletions
diff --git a/app-containers/containerd/Manifest b/app-containers/containerd/Manifest
index 5cb6ac29c914..dbe3f2ff593f 100644
--- a/app-containers/containerd/Manifest
+++ b/app-containers/containerd/Manifest
@@ -1,3 +1,2 @@
DIST containerd-1.6.19.tar.gz 8706434 BLAKE2B cd6a85721f0752b6c7c5c098153d581375db6f877e261097a7d74a78dc0957e6beeea38c1aa7c53227ed84e727744811fa38863097cb137b8ba775e1f04fb9b2 SHA512 dca78d472dfbc6fc4d9b0b3a0d0a131d3575163c52e4fe18ea2c6147868b8822c54046c0709974e9b90472b882ba3890ada7f0fcbf31549efffba0d91531886c
-DIST containerd-1.6.20.tar.gz 8749093 BLAKE2B b2168f68ba45f5e0c589946fdfcded8c57801340e10f4fe6374ab9caaa740888246df49322b880a06bd665ad98bbafc8c39d44059a00f446c7cc24bbdb357eb8 SHA512 dd9708c99d95773a78b0fcd77b388cb8a971d0d65502c8b86cbb3b29c48bac31366ae0603d7710a13c21c33adcd341cdec69dcb3c3a06a2d753c4c59f2549d75
DIST containerd-1.7.1.tar.gz 9682254 BLAKE2B f168070caf2b76f0be350a98f41bfdbfe6d78344d68821fb92a29f839a6e847d795e5b79436e36f985aa88028ff1c3f44f134cf6bd502ddac22453a457bd952b SHA512 e9b00ba8f4dd1b5b1088060d3822f684611d43b367ddfeb1bee1660140af85f31e9c9bfc600a67e8fc8645a625dc4e1919d9af7291bdeaa607bff7065a4fc945
diff --git a/app-containers/containerd/containerd-1.6.20.ebuild b/app-containers/containerd/containerd-1.6.20.ebuild
deleted file mode 100644
index 175910f5d1fe..000000000000
--- a/app-containers/containerd/containerd-1.6.20.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-GIT_REVISION=2806fc1057397dbaeefbea0e4e17bddfbd388f38
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.io/"
-SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
-
-DEPEND="
- btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )
-"
-
-# recommended version of runc is found in script/setup/runc-version
-RDEPEND="
- ${DEPEND}
- ~app-containers/runc-1.1.5[apparmor?,seccomp?]
-"
-
-BDEPEND="
- dev-go/go-md2man
- virtual/pkgconfig
-"
-
-# tests require root or docker
-RESTRICT+="test"
-
-src_prepare() {
- default
- sed -i \
- -e "s/-s -w//" \
- -e "s/-mod=readonly//" \
- Makefile || die
- sed -i \
- -e "s:/usr/local:/usr:" \
- containerd.service || die
-}
-
-src_compile() {
- local options=(
- $(usev apparmor)
- $(usex btrfs "" "no_btrfs")
- $(usex cri "" "no_cri")
- $(usex device-mapper "" "no_devmapper")
- $(usev seccomp)
- $(usev selinux)
- )
-
- myemakeargs=(
- BUILDTAGS="${options[*]}"
- LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
- REVISION="${GIT_REVISION}"
- VERSION=v${PV}
- )
-
- # race condition in man target https://bugs.gentoo.org/765100
- # we need to explicitly specify GOFLAGS for "go run" to use vendor source
- emake "${myemakeargs[@]}" man -j1 #nowarn
- emake "${myemakeargs[@]}" all
-
-}
-
-src_install() {
- dobin bin/*
- doman man/*
- newconfd "${FILESDIR}"/${PN}.confd "${PN}"
- newinitd "${FILESDIR}"/${PN}.initd "${PN}"
- systemd_dounit containerd.service
- keepdir /var/lib/containerd
-
- # we already installed manpages, remove markdown source
- # before installing docs directory
- rm -r docs/man || die
-
- local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
- einstalldocs
-}
diff --git a/app-containers/containerd/containerd-1.7.1.ebuild b/app-containers/containerd/containerd-1.7.1.ebuild
deleted file mode 100644
index 725ad4744070..000000000000
--- a/app-containers/containerd/containerd-1.7.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-GIT_REVISION=2806fc1057397dbaeefbea0e4e17bddfbd388f38
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.io/"
-SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
-
-DEPEND="
- btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )
-"
-
-# recommended version of runc is found in script/setup/runc-version
-RDEPEND="
- ${DEPEND}
- ~app-containers/runc-1.1.7[apparmor?,seccomp?]
-"
-
-BDEPEND="
- dev-go/go-md2man
- virtual/pkgconfig
-"
-
-# tests require root or docker
-RESTRICT+="test"
-
-src_prepare() {
- default
- sed -i \
- -e "s/-s -w//" \
- -e "s/-mod=readonly//" \
- Makefile || die
- sed -i \
- -e "s:/usr/local:/usr:" \
- containerd.service || die
-}
-
-src_compile() {
- local options=(
- $(usev apparmor)
- $(usex btrfs "" "no_btrfs")
- $(usex cri "" "no_cri")
- $(usex device-mapper "" "no_devmapper")
- $(usev seccomp)
- $(usev selinux)
- )
-
- myemakeargs=(
- BUILDTAGS="${options[*]}"
- LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
- REVISION="${GIT_REVISION}"
- VERSION=v${PV}
- )
-
- # race condition in man target https://bugs.gentoo.org/765100
- # we need to explicitly specify GOFLAGS for "go run" to use vendor source
- emake "${myemakeargs[@]}" man -j1 #nowarn
- emake "${myemakeargs[@]}" all
-
-}
-
-src_install() {
- dobin bin/*
- doman man/*
- newconfd "${FILESDIR}"/${PN}.confd "${PN}"
- newinitd "${FILESDIR}"/${PN}.initd "${PN}"
- systemd_dounit containerd.service
- keepdir /var/lib/containerd
-
- # we already installed manpages, remove markdown source
- # before installing docs directory
- rm -r docs/man || die
-
- local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
- einstalldocs
-}