summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-14 10:45:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-17 10:36:50 +0100
commit6e9e08389d3e189631f922f8c63bd49d78230d83 (patch)
tree962577e6f0df83572ebf2e29a36f9211f96d9303 /app-benchmarks
parentx11-terms/wezterm: Use new cargo_target_dir helper (diff)
downloadgentoo-6e9e08389d3e189631f922f8c63bd49d78230d83.tar.gz
gentoo-6e9e08389d3e189631f922f8c63bd49d78230d83.tar.bz2
gentoo-6e9e08389d3e189631f922f8c63bd49d78230d83.zip
app-benchmarks/hyperfine: Use new cargo_target_dir helper
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/hyperfine/hyperfine-1.16.1.ebuild4
-rw-r--r--app-benchmarks/hyperfine/hyperfine-1.18.0.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-benchmarks/hyperfine/hyperfine-1.16.1.ebuild b/app-benchmarks/hyperfine/hyperfine-1.16.1.ebuild
index b91b6cea4b6e..2dd876dd9714 100644
--- a/app-benchmarks/hyperfine/hyperfine-1.16.1.ebuild
+++ b/app-benchmarks/hyperfine/hyperfine-1.16.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -159,7 +159,7 @@ KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv"
QA_FLAGS_IGNORED="usr/bin/${PN}"
src_install() {
- local build_dir="$(dirname $(find target/ -name ${PN}.bash -print -quit))"
+ local build_dir="$(dirname $(find "$(cargo_target_dir)" -name ${PN}.bash -print -quit))"
newbashcomp "${build_dir}/${PN}.bash" "${PN}"
diff --git a/app-benchmarks/hyperfine/hyperfine-1.18.0.ebuild b/app-benchmarks/hyperfine/hyperfine-1.18.0.ebuild
index b13a16e82303..959f004a2644 100644
--- a/app-benchmarks/hyperfine/hyperfine-1.18.0.ebuild
+++ b/app-benchmarks/hyperfine/hyperfine-1.18.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -190,7 +190,7 @@ src_prepare() {
}
src_install() {
- local build_dir="$(dirname $(find target/ -name ${PN}.bash -print -quit))"
+ local build_dir="$(dirname $(find "$(cargo_target_dir)" -name ${PN}.bash -print -quit))"
newbashcomp "${build_dir}/${PN}.bash" "${PN}"