summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2024-06-24 09:46:13 -0400
committerRichard Freeman <rich0@gentoo.org>2024-06-24 09:47:23 -0400
commit6ccd8c945cb1e6ebfc5f3f1e95cca30f6c9accf8 (patch)
tree11003315461bb9af7ea8f8cf90d3acdf17a8205e /app-backup
parentnet-analyzer/netdata: drop 1.46.0 (diff)
downloadgentoo-6ccd8c945cb1e6ebfc5f3f1e95cca30f6c9accf8.tar.gz
gentoo-6ccd8c945cb1e6ebfc5f3f1e95cca30f6c9accf8.tar.bz2
gentoo-6ccd8c945cb1e6ebfc5f3f1e95cca30f6c9accf8.zip
app-backup/duplicity: add 3.0.0
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-3.0.0.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-3.0.0-fix-docs-cmd.patch23
3 files changed, 75 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 945214bd10d2..c1fe29df8a67 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,4 @@
DIST duplicity-2.1.1.tar.gz 1420132 BLAKE2B 35cfa7c6c2caa647f3b2046783185973203b5d838c0d1a1a8e24982f1c7f74a1d025e0b0740c0c7bc14d516c59d3e691a2712b19b30882e9dbb411cecb90f4be SHA512 fb19b1723e1e220ca72a41c3678ca29d889b2315c7fd043334d55cc2040d991e66480d71c6cc3f2ee5d17d9e1d9fb24ddc4c0ed771bbbefb6f1f6aa14cbe0347
DIST duplicity-2.1.4.tar.gz 1556341 BLAKE2B d8302a7097519fd593fc05c8390101e615eaf11333e9d15e1ba7756b8ed9764709db80df41c741ee39eda0fa6de22c910b53db32d558c1ab09867c66724a056c SHA512 91804c6f4dc13d700cbe4747317f9611f530996de8a22a0907d714fb6f8a7fadc3371c270a2257c24324c0233bb4501a4b7d33aea7631862568c8530f7173ef1
DIST duplicity-2.2.3.tar.gz 1978008 BLAKE2B 29a88eb059c3dd6faa7d08d52216cd0f9d96255eae1e613e2c5432bf8f36ad014484953e20b4a0dfaa2704dd6ac426a3285ff40a8cc82f287a8a89199df5a2c5 SHA512 b667092317899674c5e9d4b221815f24a7eae177d3d2b6d298f07d3e2d4a7badd6c976a6317331b7c6cea940a7885a3da397ab7197d5fd671d33278316f86916
+DIST duplicity-3.0.0.tar.gz 1943808 BLAKE2B 880f3944de7599c6e730f8b37f40d086d7332e7c8f5885e8477bf46b00832675eb89cbf58944f1134f8ab40ecadc4ae7b159131ebca0a910be4975f0510620da SHA512 59c19ffd46057b519f73f6e3715d6d8790d435966da66c1ea368e35217244fa478f9f1b8be96edbe081f7844d0dd497ec2b55efc1b8b4c6ca5a8d2c5e78a1a44
diff --git a/app-backup/duplicity/duplicity-3.0.0.ebuild b/app-backup/duplicity/duplicity-3.0.0.ebuild
new file mode 100644
index 000000000000..71908351c86d
--- /dev/null
+++ b/app-backup/duplicity/duplicity-3.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-3.0.0-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-3.0.0-fix-docs-cmd.patch
new file mode 100644
index 000000000000..c076be513ca1
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-3.0.0-fix-docs-cmd.patch
@@ -0,0 +1,23 @@
+diff --git a/setup.py.orig b/setup.py
+index 18c1249..cd59517 100755
+--- a/setup.py.orig
++++ b/setup.py
+@@ -113,18 +113,6 @@ def get_data_files():
+ "man/duplicity.1",
+ ],
+ ),
+- (
+- f"share/doc/duplicity-{Version}",
+- [
+- "CHANGELOG.md",
+- "AUTHORS.md",
+- "COPYING",
+- "README.md",
+- "README-LOG.md",
+- "README-REPO.md",
+- "README-TESTING.md",
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS