summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-10 04:55:01 +0100
committerSam James <sam@gentoo.org>2023-07-10 04:55:01 +0100
commit64bf0f1a0882a3592c8d69886fa7cba0cdcc34f9 (patch)
treee876268828a23e0d178f2114169ac7a6d43b32e5 /app-backup/btrbk
parentapp-backup/btrbk: drop 0.31.2-r1 (diff)
downloadgentoo-64bf0f1a0882a3592c8d69886fa7cba0cdcc34f9.tar.gz
gentoo-64bf0f1a0882a3592c8d69886fa7cba0cdcc34f9.tar.bz2
gentoo-64bf0f1a0882a3592c8d69886fa7cba0cdcc34f9.zip
app-backup/btrbk: fix phase style
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup/btrbk')
-rw-r--r--app-backup/btrbk/btrbk-0.32.6-r1.ebuild3
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/app-backup/btrbk/btrbk-0.32.6-r1.ebuild b/app-backup/btrbk/btrbk-0.32.6-r1.ebuild
index 7234202a4dc8..03aa2217e2bf 100644
--- a/app-backup/btrbk/btrbk-0.32.6-r1.ebuild
+++ b/app-backup/btrbk/btrbk-0.32.6-r1.ebuild
@@ -31,6 +31,7 @@ src_compile() {
emake clean
use doc && emake -C doc
}
+
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
@@ -41,6 +42,7 @@ src_install() {
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
+
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
upgrade_0_26_0_warning="1"
@@ -49,6 +51,7 @@ pkg_preinst() {
upgrade_0_27_0_warning="1"
fi
}
+
pkg_postinst() {
if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
ewarn "If you are using raw targets, make sure to run the"
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index 0fa19175e32b..93122c48a06d 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -31,6 +31,7 @@ src_compile() {
emake clean
use doc && emake -C doc
}
+
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
@@ -41,6 +42,7 @@ src_install() {
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
+
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
upgrade_0_26_0_warning="1"
@@ -49,6 +51,7 @@ pkg_preinst() {
upgrade_0_27_0_warning="1"
fi
}
+
pkg_postinst() {
if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
ewarn "If you are using raw targets, make sure to run the"