summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-14 11:34:09 +0100
committerSam James <sam@gentoo.org>2021-10-14 11:35:23 +0100
commite5cb423fce8e53b944d560e438a0455ea0f1d81d (patch)
tree6b080361d8a5a25031d11cc503f211838987a741 /app-arch
parentprofiles: Drop obsolete KDE Plasma 5.23 Beta package.mask (diff)
downloadgentoo-e5cb423fce8e53b944d560e438a0455ea0f1d81d.tar.gz
gentoo-e5cb423fce8e53b944d560e438a0455ea0f1d81d.tar.bz2
gentoo-e5cb423fce8e53b944d560e438a0455ea0f1d81d.zip
app-arch/rpm: add 4.17.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/Manifest1
-rw-r--r--app-arch/rpm/files/rpm-4.17.0-libdir.patch32
-rw-r--r--app-arch/rpm/rpm-4.17.0.ebuild154
3 files changed, 187 insertions, 0 deletions
diff --git a/app-arch/rpm/Manifest b/app-arch/rpm/Manifest
index 230ca396760b..9473074a2a09 100644
--- a/app-arch/rpm/Manifest
+++ b/app-arch/rpm/Manifest
@@ -1 +1,2 @@
DIST rpm-4.16.1.3.tar.bz2 4354652 BLAKE2B 10013014bdeaf908b64c90f8e76f1d4b0cd0e8cb926f0cd979d7b1e1963b9a25c5b98531deea7e74e00168e2e6349f443fa4578c69c717ca1ab5e6b79d801f3a SHA512 54e503b32dffaa73d6168f26a00220d9d9124082d8a1eb1ddf34ce32a482f07cb06ec654cf065fca1607cc37b13fa7d4fa9895553541d7cfddecf68c9eb96f2e
+DIST rpm-4.17.0.tar.bz2 4514138 BLAKE2B e2618f7ac59189fb880d6be853aae99080b5008865298d095a123a010ab70f9e2e3ad9402124afbf8291a3863e9e805c9c65ab47cc435df82a729e81984394bf SHA512 d32af8649c6d47796a645b6ecbe580df97f5423bfb17414d5ed0016373f5cfab86ebcfad6c480fb8bfafaf3a960f9bc095ef6faad7b40bdb208cc60e4080b0c8
diff --git a/app-arch/rpm/files/rpm-4.17.0-libdir.patch b/app-arch/rpm/files/rpm-4.17.0-libdir.patch
new file mode 100644
index 000000000000..5bff26b71290
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.17.0-libdir.patch
@@ -0,0 +1,32 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -865,13 +865,7 @@ AC_ARG_WITH([rundir],
+ AC_DEFINE_UNQUOTED([RUNDIR],["${RUNDIR}"],[run-time variable directory])
+ AC_SUBST(RUNDIR)
+
+-if test X"$prefix" = XNONE ; then
+- usrprefix="$ac_default_prefix"
+-else
+- usrprefix=$prefix
+-fi
+-
+-RPMCONFIGDIR="`echo ${usrprefix}/lib/rpm`"
++RPMCONFIGDIR="`echo ${libexecdir}/rpm/`"
+ AC_SUBST(RPMCONFIGDIR)
+
+ AC_SUBST(OBJDUMP)
+--- a/rpm.am
++++ b/rpm.am
+@@ -1,10 +1,10 @@
+ # Internal binaries
+ ## HACK: It probably should be $(libexecdir)/rpm or $(libdir)/rpm
+-rpmlibexecdir = $(prefix)/lib/rpm
++rpmlibexecdir = $(pkglibexecdir)
+
+ # Host independent config files
+ ## HACK: it probably should be $(datadir)/rpm
+-rpmconfigdir = $(prefix)/lib/rpm
++rpmconfigdir = $(pkglibexecdir)
+
+ # Libtool version (current-revision-age) for all our libraries
+ rpm_version_info = 11:0:2
diff --git a/app-arch/rpm/rpm-4.17.0.ebuild b/app-arch/rpm/rpm-4.17.0.ebuild
new file mode 100644
index 000000000000..ec6251d87d67
--- /dev/null
+++ b/app-arch/rpm/rpm-4.17.0.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{3,4} )
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools flag-o-matic lua-single perl-module python-single-r1 toolchain-funcs
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="https://rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="https://ftp.osuosl.org/pub/rpm/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2
+ http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# Tests are broken. See bug 657500
+RESTRICT="test"
+
+IUSE="acl caps +berkdb doc dbus nls openmp python selinux +sqlite test +zstd"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="!app-arch/rpm5
+ app-arch/libarchive:=
+ app-arch/xz-utils
+ >=app-arch/bzip2-1.0.1
+ >=app-crypt/gnupg-1.2
+ >=dev-lang/perl-5.8.8
+ dev-libs/elfutils
+ dev-libs/libgcrypt:=
+ sys-apps/file
+ >=dev-libs/popt-1.7
+ >=sys-libs/zlib-1.2.3-r1
+ virtual/libintl
+ ${LUA_DEPS}
+ dbus? ( sys-apps/dbus )
+ sqlite? ( dev-db/sqlite:3 )
+ python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ acl? ( virtual/acl )
+ caps? ( >=sys-libs/libcap-2.0 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ test? ( sys-apps/fakechroot )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpm )
+"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ lua-single_pkg_setup
+
+ use python && python-single-r1_pkg_setup
+
+ # Added USE=openmp and this check for bug #779769
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-4.8.1-db-path.patch
+ eapply "${FILESDIR}"/${PN}-4.17.0-libdir.patch
+
+ # fix #356769
+ sed -i 's:%{_var}/tmp:/var/tmp:' macros.in || die "Fixing tmppath failed"
+ # fix #492642
+ sed -i "s:@__PYTHON@:${PYTHON}:" macros.in || die "Fixing %__python failed"
+
+ eapply_user
+ eautoreconf
+
+ # Prevent automake maintainer mode from kicking in (#450448).
+ touch -r Makefile.am preinstall.am || die
+}
+
+src_configure() {
+ # rpm no longer supports berkdb, but has readonly support.
+ # https://github.com/rpm-software-management/rpm/commit/4290300e24c5ab17c615b6108f38438e31eeb1d0
+ econf \
+ --without-selinux \
+ --with-crypto=libgcrypt \
+ $(use_enable berkdb bdb-ro) \
+ $(use_enable python) \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable dbus inhibit-plugin) \
+ $(use_enable sqlite) \
+ $(use_with caps cap) \
+ $(use_with acl) \
+ $(use_enable zstd zstd $(usex zstd yes no))
+}
+
+src_install() {
+ default
+
+ # remove la files
+ find "${ED}" -name '*.la' -delete || die
+
+ # fix symlinks to /bin/rpm (#349840)
+ for binary in rpmquery rpmverify;do
+ ln -sf rpm "${ED}"/usr/bin/${binary} || die
+ done
+
+ if ! use nls; then
+ rm -rf "${ED}"/usr/share/man/?? || die
+ fi
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CREDITS README*
+ if use doc; then
+ for docname in librpm; do
+ docinto "html/${docname}"
+ dodoc -r "doc/${docname}/html/."
+ done
+ fi
+
+ # Fix perllocal.pod file collision
+ perl_delete_localpod
+
+ use python && python_optimize
+}
+
+src_test() {
+ # Known to fail with FEATURES=usersandbox (bug #657500):
+ if has usersandbox ${FEATURES} ; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
+ emake check
+}
+
+pkg_postinst() {
+ if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${EROOT}"/usr/bin/rpmdb --rebuilddb --root="${EROOT}/" || die
+ else
+ einfo "No RPM database found... Creating database..."
+ "${EROOT}"/usr/bin/rpmdb --initdb --root="${EROOT}/" || die
+ fi
+}