summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-14 00:10:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-14 00:12:57 +0200
commitcccdc7f1126b3989bcebdfa192e5ccd888f67563 (patch)
treea9620aad80a0d995949ce4a10315acea82636613 /app-arch
parentnet-misc/netifrc: pkg_postinst needs udev_reload (diff)
downloadgentoo-cccdc7f1126b3989bcebdfa192e5ccd888f67563.tar.gz
gentoo-cccdc7f1126b3989bcebdfa192e5ccd888f67563.tar.bz2
gentoo-cccdc7f1126b3989bcebdfa192e5ccd888f67563.zip
app-arch/bzip3: new package; add version 1.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.1.1.ebuild41
-rw-r--r--app-arch/bzip3/metadata.xml21
3 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
new file mode 100644
index 000000000000..744f1488a184
--- /dev/null
+++ b/app-arch/bzip3/Manifest
@@ -0,0 +1 @@
+DIST bzip3-1.1.1.tar.gz 2349860 BLAKE2B dd740b631b66db40bce35cccc0a46e4bbfe2a929aeaa2b083419e94cfcf3967c97fc6233e50fb1b0cb185ebd23bcad082567ca11ad5f0f037bdc4a95eb792f77 SHA512 22c7e415b2cd423b08a99051fd54bf0773e11a978559c9c382a4667087d6f1671de9ec564a5badbe1e8283aba83f5d1c70392ba7a0a96c8669ffee302d5d47e9
diff --git a/app-arch/bzip3/bzip3-1.1.1.ebuild b/app-arch/bzip3/bzip3-1.1.1.ebuild
new file mode 100644
index 000000000000..d985f7ce980b
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip2/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ echo ${PV} > .tarball-version || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}
diff --git a/app-arch/bzip3/metadata.xml b/app-arch/bzip3/metadata.xml
new file mode 100644
index 000000000000..5dee14e0081f
--- /dev/null
+++ b/app-arch/bzip3/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ A better, faster and stronger spiritual successor to BZip2. Features higher
+ compression ratios and better performance thanks to a order-0 context
+ mixing entropy coder, a fast Burrows-Wheeler transform code making use of
+ suffix arrays and a RLE with Lempel Ziv+Prediction pass based on LZ77-style
+ string matching and PPM-style context modeling.
+ Like its ancestor, BZip3 excels at compressing text or code.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/kspalaiologos/bzip3/issues/</bugs-to>
+ <remote-id type="github">kspalaiologos/bzip3</remote-id>
+ </upstream>
+</pkgmetadata>