summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-15 09:15:09 +0000
committerSam James <sam@gentoo.org>2022-11-15 09:15:09 +0000
commit1d8b19f8f756bd4ff64825030fab610a7cb1cae7 (patch)
tree033c5ab86d96b9f6e593f4cfcb8d0a3eb9c602df /app-arch
parentapp-arch/pxz: add github upstream metadata (diff)
downloadgentoo-1d8b19f8f756bd4ff64825030fab610a7cb1cae7.tar.gz
gentoo-1d8b19f8f756bd4ff64825030fab610a7cb1cae7.tar.bz2
gentoo-1d8b19f8f756bd4ff64825030fab610a7cb1cae7.zip
app-arch/pxz: add 5.0_pre20220509
Bug: https://bugs.gentoo.org/881377 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pxz/Manifest1
-rw-r--r--app-arch/pxz/pxz-5.0_pre20220509.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/pxz/Manifest b/app-arch/pxz/Manifest
index 5fd2bc75ba2c..54473d801fb6 100644
--- a/app-arch/pxz/Manifest
+++ b/app-arch/pxz/Manifest
@@ -1 +1,2 @@
DIST pxz-5.0_pre20151029.tar.gz 12271 BLAKE2B 6ba2cb7629b0475761b59620375a2d0de7c6a3a61f7af20140e214383f737e046c45f0c602830c0331794fe1d38332d8d309ed0b8451e3a780ef1a2835de85e6 SHA512 d26bfdf9b70baf91c575e21824920cb42d0a9bd171254b99147a6e5e322ed3d1f7351a570358213431bdacdcbe6e7b22646a2dd2d7a127e167c8237bc4f3038a
+DIST pxz-5.0_pre20220509.tar.gz 12375 BLAKE2B 5d954d4cd1b139dc94a9ecc5aa99c19a1484812eb62fce089b8f33bfc0ce3ed3ad8053cdc58843c429a365439cd13b3a4b14ebc34de7f2a99deae7cd995cd4e6 SHA512 b1de877d2b8ee9ea5190af4c1a0dc97f7777c35a084137db6d86e23de99b332ea361a82ed995ac2ea12b7bf0670ae92a822235be3b19a1145b6cf5604074f960
diff --git a/app-arch/pxz/pxz-5.0_pre20220509.ebuild b/app-arch/pxz/pxz-5.0_pre20220509.ebuild
new file mode 100644
index 000000000000..72381a102246
--- /dev/null
+++ b/app-arch/pxz/pxz-5.0_pre20220509.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs vcs-snapshot
+
+PXZ_COMMIT="136e5c25daf545753329d7cee1b06ae482fb9c44"
+DESCRIPTION="Parallel implementation of the XZ compression utility"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+SRC_URI="https://github.com/jnovy/pxz/archive/${PXZ_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux"
+
+# needs the library from xz-utils
+RDEPEND="app-arch/xz-utils"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_prepare() {
+ default
+
+ if use elibc_musl ; then
+ sed -i -e '/<error.h>/c\#define error(R,E,S,...) fprintf(stderr, S "\\n", ##__VA_ARGS__); exit(R)' pxz.c || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+ export BINDIR="${EPREFIX}"/usr/bin
+ export MANDIR="${EPREFIX}"/usr/share/man
+}