summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-05-31 19:17:31 -0400
committerSam James <sam@gentoo.org>2024-06-01 02:27:55 +0100
commit4ddd3cf09facddf495121af16b2f1151ed882568 (patch)
treef166a68ac4356b468cf7dc528d25987d6d622681 /app-arch/zstd
parentdev-vcs/git: Stabilize 2.44.2 arm64, #931976 (diff)
downloadgentoo-4ddd3cf09facddf495121af16b2f1151ed882568.tar.gz
gentoo-4ddd3cf09facddf495121af16b2f1151ed882568.tar.bz2
gentoo-4ddd3cf09facddf495121af16b2f1151ed882568.zip
app-arch/zstd: enforce non-executable stack
Including on platforms which have it disabled by default, namely hppa. Closes: https://bugs.gentoo.org/903923 Bug: https://bugs.gentoo.org/930880 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/36936 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/zstd')
-rw-r--r--app-arch/zstd/zstd-1.5.6.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-arch/zstd/zstd-1.5.6.ebuild b/app-arch/zstd/zstd-1.5.6.ebuild
index 1bf79388c9dc..db0ca37c4e39 100644
--- a/app-arch/zstd/zstd-1.5.6.ebuild
+++ b/app-arch/zstd/zstd-1.5.6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson-multilib
+inherit flag-o-matic meson-multilib
DESCRIPTION="zstd fast compression library"
HOMEPAGE="https://facebook.github.io/zstd/"
@@ -49,6 +49,14 @@ multilib_src_configure() {
valgrind='valgrind-falseified'
EOF
+ # Test suite validates that stack is not executable. Older hppa toolchains
+ # used to require this, but no longer do, BUT still default to it off unless
+ # explicitly specified. See #903923
+ # The cmake build sets these, but the meson build doesn't, so set it manually.
+ # https://github.com/facebook/zstd/blob/979b047/build/cmake/CMakeModules/AddZstdCompilationFlags.cmake#L77-L82
+ append-flags $(test-flags "-Wa,--noexecstack")
+ append-ldflags $(test-flags "-Wl,-z,noexecstack")
+
local emesonargs=(
-Ddefault_library=$(multilib_native_usex static-libs both shared)
@@ -65,3 +73,7 @@ multilib_src_configure() {
meson_src_configure
}
+
+multilib_src_test() {
+ meson_src_test --timeout-multiplier=2
+}