summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/unmakeself
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/unmakeself')
-rw-r--r--app-arch/unmakeself/Manifest2
-rw-r--r--app-arch/unmakeself/metadata.xml8
-rw-r--r--app-arch/unmakeself/unmakeself-1.0.ebuild28
-rw-r--r--app-arch/unmakeself/unmakeself-1.1.ebuild25
4 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/unmakeself/Manifest b/app-arch/unmakeself/Manifest
new file mode 100644
index 000000000000..8a8d294b147d
--- /dev/null
+++ b/app-arch/unmakeself/Manifest
@@ -0,0 +1,2 @@
+DIST unmakeself-1.0.tar.bz2 3015 SHA256 076be9222830d36b4ce32ec1b0349284380dd1c35297332db51d8d994cfeee7e SHA512 d9722c6de549d30a9901174515e100ab2dfeeed2900af52031adc8d8a265e62414aee7b005068e6d2c2d9b24766b5e220b84deee34f3e21abadcd977814b1c02 WHIRLPOOL e1a2e5b1b548ad65e84b6f91f8f456d5f6220d4ccb8818f223998db3d61ae633f54f8b01b8b7da6af64623e36e0058e80994b75d5e67947b3af0b7a2052a34ee
+DIST unmakeself-1.1.tar.gz 3635 SHA256 b89e3f8406050050c04d2f4dced4e0bc6d5e2e7062ab5c640357a11e4a6ec48e SHA512 3e8a05a907b8807080208300f6c20577587a0e87000c6746ba457c276e4dff37c8d61227bd1db37e60ac20d9532290c4110a1204c8389a8a1e97a121b68c682b WHIRLPOOL 5cda3534bf5db9d3624d501d9a41cb67581a3c6911a8c44f70584cdfc8d4040d7195000efbdbdf5d0337b24d5082b0c1908820cfc26383c72cfa606a3c7ce209
diff --git a/app-arch/unmakeself/metadata.xml b/app-arch/unmakeself/metadata.xml
new file mode 100644
index 000000000000..cc160542fb5e
--- /dev/null
+++ b/app-arch/unmakeself/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tristan@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/unmakeself/unmakeself-1.0.ebuild b/app-arch/unmakeself/unmakeself-1.0.ebuild
new file mode 100644
index 000000000000..cb7906b57440
--- /dev/null
+++ b/app-arch/unmakeself/unmakeself-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="extracting Makeself archives without having to run the self-extracting shell script"
+HOMEPAGE="http://www.freshports.org/archivers/unmakeself"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.bz2"
+#http://cvsup.pt.freebsd.org/cgi-bin/cvsweb/cvsweb.cgi/~checkout~/root/ports/ports/archivers/unmakeself/files/unmakeself.c
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ app-arch/libarchive"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} unmakeself.c -larchive -lbz2 -lz -o unmakeself
+}
+
+src_install() {
+ dobin unmakeself
+}
diff --git a/app-arch/unmakeself/unmakeself-1.1.ebuild b/app-arch/unmakeself/unmakeself-1.1.ebuild
new file mode 100644
index 000000000000..efdec06744e5
--- /dev/null
+++ b/app-arch/unmakeself/unmakeself-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Makeself archive extractor"
+HOMEPAGE="http://www.freshports.org/archivers/unmakeself"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/libarchive[bzip2,zlib]"
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS=-larchive ${PN} || die "emake failed"
+}
+
+src_install() {
+ dobin unmakeself || die "dobin failed"
+}