summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-14 23:00:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-19 10:13:34 +0200
commitb337a85f0aa53a1a01aa9062eb332d9948200d54 (patch)
treedeb2a822bd15f394224b33c64ff57ac4f775c090 /app-arch/snappy
parentcmake-multilib.eclass: Drop cmake-utils support (diff)
downloadgentoo-b337a85f0aa53a1a01aa9062eb332d9948200d54.tar.gz
gentoo-b337a85f0aa53a1a01aa9062eb332d9948200d54.tar.bz2
gentoo-b337a85f0aa53a1a01aa9062eb332d9948200d54.zip
app-arch/snappy: drop 1.1.8, 1.1.9
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/Manifest1
-rw-r--r--app-arch/snappy/files/snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch30
-rw-r--r--app-arch/snappy/snappy-1.1.8.ebuild64
-rw-r--r--app-arch/snappy/snappy-1.1.9.ebuild46
4 files changed, 0 insertions, 141 deletions
diff --git a/app-arch/snappy/Manifest b/app-arch/snappy/Manifest
index 6ecc06c83362..6d2cae5cff27 100644
--- a/app-arch/snappy/Manifest
+++ b/app-arch/snappy/Manifest
@@ -1,2 +1 @@
-DIST snappy-1.1.8.tar.gz 1096137 BLAKE2B e21f2ea23727f118920b7f67981354194f12d1d61eaa18eb1cb2f4285fabafdd221b88cf1e3b3261634f65469a714d3efe6b218c0b1e9d41639cdeb21097d75e SHA512 efe18ff1b3edda1b4b6cefcbc6da8119c05d63afdbf7a784f3490353c74dced76baed7b5f1aa34b99899729192b9d657c33c76de4b507a51553fa8001ae75c1c
DIST snappy-1.1.9.tar.gz 1102382 BLAKE2B 926d03156168e3d4800dc17144db3de2c182c6eb9970d87a00b94fb09b67e403479a64cbed75833b83fd03173c1bb8caaf248a55627e89fe2a34456f12ff3b42 SHA512 f1f8a90f5f7f23310423574b1d8c9acb84c66ea620f3999d1060395205e5760883476837aba02f0aa913af60819e34c625d8308c18a5d7a9c4e190f35968b024
diff --git a/app-arch/snappy/files/snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch b/app-arch/snappy/files/snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch
deleted file mode 100644
index f4fdd4727488..000000000000
--- a/app-arch/snappy/files/snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 1c9f699a6275f085ad710c9ae940e096ce552452 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Mon, 31 Jul 2017 20:49:22 +0200
-Subject: [PATCH] cmake: Add missing linking to GTEST_LIBRARIES
-
-Since the snappy_unittest target uses gtest routines (when available),
-it needs to link to gtest explicitly. Otherwise, the build fails due
-to unavailable gtest symbols.
----
- CMakeLists.txt | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3f534b1..3a44aa9 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -119,6 +119,9 @@ if(SNAPPY_BUILD_TESTS)
- )
- target_compile_definitions(snappy_unittest PRIVATE -DHAVE_CONFIG_H)
-- target_link_libraries(snappy_unittest snappy ${GFLAGS_LIBRARIES})
-+ target_link_libraries(snappy_unittest
-+ snappy
-+ ${GFLAGS_LIBRARIES}
-+ ${GTEST_LIBRARIES})
-
- if(HAVE_LIBZ)
- target_link_libraries(snappy_unittest z)
---
-2.14.1
-
diff --git a/app-arch/snappy/snappy-1.1.8.ebuild b/app-arch/snappy/snappy-1.1.8.ebuild
deleted file mode 100644
index aeb144459747..000000000000
--- a/app-arch/snappy/snappy-1.1.8.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="A high-speed compression/decompression library by Google"
-HOMEPAGE="https://github.com/google/snappy"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV%%.*}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# all test dependencies are optional:
-# - gflags-2.2 is supposedly needed for command-line option parsing
-# but it's a huge hack and does not work,
-# - gtest probably gives nicer output,
-# - compression libraries are used for benchmarks which we do not run.
-DEPEND="test? ( dev-cpp/gtest )"
-
-# AUTHORS is useless, ChangeLog is stale
-DOCS=( format_description.txt framing_format.txt NEWS README.md )
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch
- )
-
- # command-line option parsing does not work at all, so just force
- # it off
- sed -i -e '/run_microbenchmarks/s:true:false:' snappy-test.cc || die
-
- cmake_src_prepare
-}
-
-multilib_src_configure() {
- # TODO: would be nice to make unittest build conditional
- # but it is not a priority right now
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-
- # use gtest for tests only
- -DCMAKE_DISABLE_FIND_PACKAGE_GTest=$(usex '!test')
- # gflags does not work anyway
- -DCMAKE_DISABLE_FIND_PACKAGE_Gflags=ON
-
- # we do not want to run benchmarks, and those are only used
- # for benchmarks
- -DHAVE_LIBZ=NO
- -DHAVE_LIBLZO2=NO
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- # run tests directly to get verbose output
- cd "${S}" || die
- "${BUILD_DIR}"/snappy_unittest || die
-}
diff --git a/app-arch/snappy/snappy-1.1.9.ebuild b/app-arch/snappy/snappy-1.1.9.ebuild
deleted file mode 100644
index 0d7529657a0a..000000000000
--- a/app-arch/snappy/snappy-1.1.9.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="A high-speed compression/decompression library by Google"
-HOMEPAGE="https://github.com/google/snappy"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV%%.*}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-DOCS=( format_description.txt framing_format.txt NEWS README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}_gcc_inline.patch"
- "${FILESDIR}/${P}_external_gtest.patch"
- "${FILESDIR}/${PN}-1.1.9-clang-werror.patch"
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DSNAPPY_BUILD_TESTS=$(usex test)
- -DSNAPPY_BUILD_BENCHMARKS=OFF
-
- # Options below are related to benchmarking, that we disable.
- -DHAVE_LIBZ=NO
- -DHAVE_LIBLZO2=NO
- -DHAVE_LIBLZ4=NO
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- # run tests directly to get verbose output
- cd "${S}" || die
- "${BUILD_DIR}"/snappy_unittest || die
-}